Skip to main content

Supported database or business systems for Talend components

This section lists the versions of databases, systems, business applications and OS that are compatible with your Talend Jobs. Their access depends on the Talend Studio monthly version you are using. For more information, see Talend Release Notes.
Systems Versions OS
Access
  • 2003
  • 2007
Information noteNote: When working with Java 8, only the General collation mode is supported.
Windows
AlloyDB Not applicable Not applicable
Amazon Aurora MySQL edition v5 (5.6 and 5.7) Not applicable
Amazon AWS Redshift Spectrum Not applicable Not applicable
Amazon Redshift 2.x Not applicable
Amazon S3 Not applicable Not applicable
Amazon Simple Queue Service (Amazon SQS) Not applicable Not applicable
AS/400 V6R1 to V7R2, V7R1 to V7R3 Not applicable
Cassandra 4.x Windows + Linux
CouchBase
  • 6.0
  • 5.x
Windows
CouchDB 1.0.2 Windows
CyberArk 12.x Not applicable
DB2
  • 11.x
  • 10.5 (and up to 11)
Not applicable
DB Generic ODBC Windows
DynamoDB Not applicable Not applicable
Elasticsearch 6.4.x for Spark Streaming Jobs Not applicable
Elasticsearch
  • 8.x for Spark Batch Jobs
  • 7.x for Spark Batch Jobs
Not applicable
Exasol 6.0 and earlier Windows
Excel Not applicable Not applicable
eXist-db 1.4.0 Not applicable
FireBird 2.1 Windows + Linux
FTP Not applicable Not applicable
Greenplum
  • 6.x
  • 5.x
  • 4.3.x
Windows (client only) + Linux
HSQLDb 1.8.0 to 2.4 Not applicable
IBM DB2 and IBM DB2 Z/OS 11.x Windows + Linux
Informix 11.50 Windows + Linux
Ingres
  • 11
  • 10.2
Windows + Linux
Interbase Not applicable Not applicable
JavaDB 6 Windows + Linux
JDBC Not applicable Not applicable
JSON Not applicable Not applicable
Kafka
  • 3.3.x
  • 3.2.x
Information noteNote: The Kerberos kinit option and the Kerberos keytab option are both supported. For information about the security options supported by the Kafka components, see Using secured Kafka with Studio.
Windows + Linux
LDAP No version limitation Windows + Linux
MapRDB Not applicable Not applicable
MarkLogic 9 Not applicable
MaxDB 7.6 Not applicable
Microsoft Azure Blob Storage Not applicable Not applicable
Microsoft Azure Synapse Analytics Not applicable Not applicable
Microsoft AX
  • Dynamics AX 2012
  • Dynamics AX 4.0
Not applicable
Microsoft CRM
  • 2016
  • 2015
  • 2011
Not applicable
Microsoft CRM Online
  • 2018
  • 2016
  • 2011
Not applicable
Microsoft SQL Server
  • Amazon RDS
  • 2014 to latest version
Information noteNote: Microsoft SQL Server support is provided through the Microsoft SQL JDBC driver. For more information, see Download Microsoft JDBC Driver for SQL Server.
Windows + Linux
MongoDB
  • 4.4.x and later for Spark Batch and Streaming Jobs
  • 4.4.x and later for Standard Jobs
Windows + Linux
MySQL
  • Google Cloud SQL
  • Amazon RDS
  • MariaDB 10.x
  • MySQL 8.x
  • MySQL 5.x
Windows + Linux
MOM Not applicable Not applicable
Neo4j
  • 4.x.x
  • 3.5.x
  • 3.2.x
Windows + Linux
Netezza
  • 11.x
  • 7.2.x
  • 7.1.x
  • 7.0.x
Windows + Linux
NetSuite
  • 2021.2
  • 2019.2
  • 2018
Windows + Linux
Oracle
  • Amazon RDS
  • Oracle 19c
  • Oracle 18c
Windows + Linux
Oracle Deprecated versions: 12 - 7/11 Not applicable
Palo Open source version 5 Not applicable
ParAccel
  • 3.5
  • 3.1
Not applicable
PostgreSQL
  • Microsoft Azure
  • Google Cloud SQL
  • Amazon RDS
  • 12 and later
Windows + Linux
PostgresPlus supported through PostgreSQL
  • 9 and later
  • 8.2
Windows + Linux
Red Hat BRMS 6.1 Windows + Linux
REST Service Not applicable Windows + Linux
Salesforce
  • 57
  • 52 and earlier
Windows + Linux
SAP 4.6 Windows + Linux
SAP Business Suite (ERP)
  • ERP6.0, From EhP6 to EhP8
  • Netweaver: From 7.3 to 7.5
Windows + Linux
SAP Business Warehouse (BW)
  • ERP6.0, From EhP6 to EhP8
  • Netweaver: From 7.3 to 7.5
Windows + Linux
SAP HANA No version limitations
Information noteNote: Supported through the SAP JDBC driver.
Windows + Linux
SAP BW/4HANA DSO components Windows + Linux
SAP BW on HANA ADSO components Windows + Linux
Snowflake Not applicable Not applicable
ServiceNow Not applicable Not applicable
SOAP Service Not applicable Not applicable
SQLite 3.6.7 Windows + Linux
Sybase
  • 17.0
  • 16.0
  • 15.7
  • 15.5
  • 15.2
  • 12.7
  • 12.5
Windows + Linux
SybaseIQ
  • 16.0
  • 15.2
  • 12.7
  • 12.5
Windows + Linux
Teradata 12 to 17 Windows + Linux
VectorWise 2 Windows + Linux
Vertica
  • 9.0.x to 9.3.1
  • 12.x
Windows + Linux
VtigerCRM
  • Vtiger 5.1
  • Vtiger 5.0
Not applicable
Workday Not applicable Not applicable

Did this page help you?

If you find any issues with this page or its content – a typo, a missing step, or a technical error – let us know how we can improve!