Skip to main content

Operating System Requirements:

  • Most popular Linux/Unix 64 bit Operation System Versions (such as Redhat).
  • About Java Dependency:
    This software is not based on code compiled for any particular Operation System OS (e.g any particular Linux distribution or version), therefore, the supported OS are 100% based on the supported OS of the underlying Java Runtime Environment (JRE) and Tomcat software (see their supported platforms for further details).
  • About Headless Linux:
    Recent versions Java Runtime Environment (JRE) such as 11 no longer bundle any fonts, and therefore rely on the underlying operating system fonts. Most bare Linux configurations bundle a minimum set of fonts, including all bare Linux VM offered on most cloud companies. However, when using an extremely bare minimum true headless Linux configuration, fontconfig and libfontconfig1 must be installed and configured on the system. Otherwise, the JRE cannot access the fonts needed in order to perform diagram rendering.
  • Microsoft supported Windows 64 bit versions (including Windows 2012 Server, Windows 2016 Server, Windows 2019 Server, Windows 2022 Server, Windows 8.1, Windows 10, and Windows 11).
  • Ensure that installer is executed with full Administrator privilege.
  • Ensure that Microsoft .NET Framework 3.5 or higher is installed.
  • Ensure that all current Microsoft Windows critical updates have been applied.

Did this page help you?

If you find any issues with this page or its content – a typo, a missing step, or a technical error – let us know how we can improve!