ESB : migration de 6.x.x vers 7.1.x - 7.1

Notes de version de Talend Data Fabric

EnrichVersion
7.1
EnrichProdName
Talend Data Fabric
task
Installation et mise à niveau

Studio

Élément

Description

Mise à niveau du Studio ESB Le Studio ESB nécessite une nouvelle installation. Vous devez exporter vos projets 6.x ou 7.0 de votre répertoire Workspace local 6.x et importer le projet avec le Studio ESB 7.1.x.
Mise à niveau du projet à distance Si vous utilisez un projet partagé (à distance), vous devez mettre à niveau Talend Administration Center dans un premier temps, puis vous connecter à votre projet à distance sans autre action requise.
Mise à niveau de projets Studio Les projets du Studio peuvent être utilisés sans aucune migration manuelle. Lorsque des instances de Services, Jobs et Routes de données sont ouvertes dans le Studio ESB, les composants qui nécessitent des modifications sont mis à niveau automatiquement.

Runtime (Moteur d'exécution)

Élément

Description

Mise à niveau d’ESB Runtime Le composant ESB Runtime (Conteneur OSGi) nécessite une nouvelle installation. Voir également Remarques sur la compatibilité des Services des données et des Routes du Studio pour plus de détails.

Talend Administration Center

Élément

Description

Mise à niveau de Talend Administration Center Talend Administration Center nécessite une nouvelle installation. Veuillez consulter le chapitre consacré à la migration dans le Guide de migration Talend.

Les pages relatives à ESB dans Talend Administration Center 7.1 n'offrent pas de rétrocompatibilité avec les anciennes versions des conteneurs, à l'exception d'ESB Conductor, qui prend toujours en charge le déploiement et l'annulation du déploiement dans les conteneurs 6.x en plus des conteneurs 7.1.

Veuillez également consulter la nouvelle page Migration dans Talend Administration Center pour comparer le projet avant et après la migration.

Migration d’ESB Identity et d’Access Management À compter de la version 6.4.1, le service Talend Identity Management (Talend IDM) basé sur Apache Syncope fourni avec Talend ESB dans le dossier add-ons/tidm n’est plus disponible dans le module Talend ESB. Le service Talend Identity Management (Talend IDM) est désormais remplacé par un service Talend Identity and Access Management plus générique qui utilise le port 9080 par défaut au lieu du port 8080. L'URL d’Identity Service dans la partie ESB Identity and Access Management de la page de configuration de Talend Administration Center doit être actualisée en conséquence. Si vous avez utilisé Talend ESB avec Talend Identity Management (basé sur Apache 1.2 Syncope) par le passé, vous devez saisir à nouveau les noms d’utilisateur et les rôles (qui sont désormais des Groups dans Syncope 2.0.2), ou suivre les étapes de la migration d’Apache Syncope 1.2 vers Apache Syncope 2.0 comme décrit dans https://syncope.apache.org/docs/reference-guide.html#migration-from-apache-syncope-1-2. Talend ESButilisait des Assignations Utilisateurs/Groupes et Utilisateur/Rôle dans Syncope 1.2. Désormais, dans Syncope 2.0.2 (version actuellement fournie avec Talend IAM), vous disposez d'assignations Utilisateurs/Groupes et Utilisateur/Rôle après la migration, ou lorsque vous spécifiez manuellement les utilisateurs. Assurez-vous que des Groupes sont utilisés à la place des Rôles utilisés par le passé dans Syncope 1.2.

Remarques sur la compatibilité des Services des données et des Routes du Studio

Élément

Description

Migration de conteneurs Talend ESB Si vous souhaitez exécuter vos instances de Services ou Routes de données sur le nouveau conteneur 7.1.x, vous devez reconstruire, republier et redéployer les modèles du Studio de manière à pouvoir utiliser les dernières modifications de code.

Nous prenons en charge l’installation mixte et l’utilisation du conteneur Talend ESB 6.x avec les instances de Services et Routes de données générées via Talend ESB Studio 6.x et Talend ESB Infrastructure Services dans 7.1.x.

Migration de Service Registry La migration de Service Registry depuis des versions antérieures vers la version 6.4.1 nécessite un export de tous les artefacts dans l'ancienne version de Service Registry (via l'interface utilisateur de TAC Service Registry ou la commande tregistry:export). Cet export complet peut ensuite être utilisé afin d’importer le contenu du Service Registry dans une nouvelle installation de ce composant effectuée pour 7.1.x.
Migration de Talend Runtime En raison d'une modification du fichier container/etc/org.talend.esb.job.saml.policy destinée à permettre l’utilisation de la suite algorithmique SHA2 au lieu de SHA1, si vous exécutez les versions de Talend Runtime antérieures à la version 6.4.1, vous devez spécifier une politique actualisée qui utilise la suite algorithmique Basic128Sha256. Cette exigence concerne uniquement les clients qui ont besoin de communiquer avec un fournisseur à partir de la version 6.4.1 et qui utilisent l’option d'authentification par jeton SAML (tESBConsumer > Authentication > SAML Token) au moment de la conception. Les clients et les fournisseurs qui utilisent Service Registry ne sont pas affectés par ce changement puisqu'ils obtiennent les politiques à partir de ce composant.
Migration des Routes du Studio À compter de la version 6.3.1, les bibliothèques du cMessageEndpoint ne sont plus fournies avec le Studio ESB. Pour plus d'informations concernant l'utilisation des Routes générées par les versions du Studio ESB antérieures à la version 6.3.1, consultez <Studio_Home>/esb/Readme_cMessageEndpoint_Libraries.txt.
Migration de Jobs Studio à l'aide de SAP avec un pool de connexions Talend Runtime Avec Talend Runtime 7.1, le nom du pool de connexions partagé doit avoir un nom fixe SAP_CONNECTION_POOL. Si vous l'avez modifié, vous devez mettre à jour vos modèles pour utiliser cette valeur fixe.