Compatible databases - 7.2

Talend Open Studio for ESB Installation and Upgrade Guide for Linux

Version
7.2
Language
English (United States)
Product
Talend Open Studio for ESB
Module
Talend ESB
Talend Runtime
Talend Studio
Content
Installation and Upgrade
The following tables provide information on the recommended and supported databases you can use with Talend server modules.

In the following documentation:

  • Recommended: designates an environment recommended by Talend based on our experiences and customer usage.
  • Supported: designates a supported environment for use with the listed component or service.
  • Supported with limitations: designates an environment that is supported by Talend but with certain conditions explained in notes.

ESB Service Registry/Authorization/Event Logging

Compatible databases for ESB Service Registry/Authorization/Event Logging
Database Version Supported drivers Support type
MySQL 8.0 1, 3 mysql-connector-java-8.x.jar Recommended
Oracle 18c ojdbc7-11g.jar

ojdbc7.jar

ojdbc8.jar

Supported
12c release 1 3 Recommended
11g Supported
Azure SQL   jtds-1.3.1_patched.jar Supported
HSQL 4 2.3.2   Supported
Derby DB 10.8 (or later)   Supported
IBM DB2 10.5   Supported
MS SQL Server 2, 3 2017 jtds-1.3.1.jar Supported
2016 Supported
2014 Supported
2012 SP2 Supported
PostgreSQL 3 11 postgresql-42.2.2.jre7.jar Supported
10 Supported
9.6 Supported
9.5 Supported

1 Google Cloud SQL is supported.

2 Talend supports the Always Encrypted feature of Microsoft SQL Server 2016 or higher.

3 Amazon RDS is supported.

4 Embedded in the product.