Exporting the report data mart settings as a context - Cloud - 8.0

Talend Studio User Guide

Version
Cloud
8.0
Language
English
Product
Talend Big Data
Talend Big Data Platform
Talend Cloud
Talend Data Fabric
Talend Data Integration
Talend Data Management Platform
Talend Data Services Platform
Talend ESB
Talend MDM Platform
Talend Real-Time Big Data Platform
Module
Talend Studio
Content
Design and Development
Last publication date
2024-02-27
Available in...

Big Data Platform

Cloud API Services Platform

Cloud Big Data Platform

Cloud Data Fabric

Cloud Data Management Platform

Data Fabric

Data Management Platform

Data Services Platform

MDM Platform

Real-Time Big Data Platform

About this task

  • You have defined the settings of the report data mart in the Preferences window as outlined in Setting up a distant database.
  • You have selected the Profiling perspective.

To export the settings of the report database as a context and use the context variables in the report editor, do the following:

Procedure

  1. In the menu bar, select Window > Preferences to display the Preferences window.
  2. Start typing Reporting in the filter field and then select Reporting from the list.
    Overview of the Reporting window.
  3. Click Export as context to open a context creation wizard.
  4. Follow the steps in the wizard to define the context variables and export as a context the data mart connection and the path of the report folder and logo file.
    A by-default name will be given to the context variables if you do not change them in the context creation wizard. The context variables will be centralized under the Contexts node in the DQ Repository tree view.
    For further information about how to centralize contexts in the Talend Studio repository, see Centralizing context variables in the Repository.
    A message appears to show the progress of the operation, and then all connection settings become read-only.
  5. To switch the connection back to its initial state, click Revert Context.
  6. In the DQ Repository tree view, right-click, one, or several analyses and generate a report.
    The report editor opens on the report settings.
    Overview of the Report Settings tab and the Context view.
    In the Database Connection Settings view at the bottom of the editor, the connection settings are already filled in with the context variables defined and exported as a context in the Preferences window.
    The Context Settings view shows the values of the context connection.
    The Context view shows the variables you exported and centralized in the Talend Studio repository, under the Contexts node in the DQ Repository tree view. If this view is not open in Talend Studio, use the combination Window > Show View > Profiling > Context to open it.
    Remember: A report created in Talend Studio before you define and export context variables keeps its initial database settings. If you want to use it with a different data mart or context connection, you must open the report and select the context connection manually from the report editor. For further information, see Selecting or updating context variables from the report editor.
  7. Save the report and execute it.
    The report results will be written to the context connection defined in the report editor.