Talend Studioでメタデータを作成および活用 - 7.3

Version
7.3
Language
日本語 (日本)
Product
Talend Big Data
Talend Big Data Platform
Talend Data Fabric
Talend Data Integration
Talend Data Management Platform
Talend Data Services Platform
Talend ESB
Talend MDM Platform
Talend Open Studio for Big Data
Talend Open Studio for Data Integration
Talend Open Studio for ESB
Talend Real-Time Big Data Platform
Module
Talend Studio
Content
ジョブデザインと開発 > ジョブデザイン

Talend Studioでメタデータを作成および活用

このチュートリアルでは、開発時間を大幅に短縮するため、Talend Studioでメタデータをどう作成して使用するかを確認できます。

このチュートリアルでは、.csvファイルを使用します。.csvファイルがない場合は、 [Downloads] (ダウンロード)タブをクリックしてcustomers_unordered.csvを保存します。

このチュートリアルではデータベースを使用します。データベースがない場合は、 [Downloads] (ダウンロード)タブをクリックしてcustomers_unordered.sqlを保存します。データベースを互換性があるプログラムにインポートする必要があります。

Talend Studioのメタデータを理解

Talend Studioによって、事前定義済みのコンポーネントを使用してジョブを作成し、実行できます。各コンポーネントは、[Built-in] (組み込み)コンポーネントまたは[Repository] (リポジトリー)コンポーネントのいずれかとして設定できます。[Repository] (リポジトリー)コンポーネントはメタデータとして保存されます。

[Built-in] (組み込み)コンポーネントの場合、ファイルの読み取り方法や含まれる内容などの情報は次のような特性を持ちます。
  • は、コンポーネントで定義されています。
  • は、このコンポーネントにのみ適用されます。
  • は、他のコンポーネントと共に再利用できません。
[Repository] (リポジトリー)コンポーネントの場合、ファイルの読み取り方法や含まれる内容などの情報は次のような特性を持ちます。
  • は、[metadata] (メタデータ)として保存されます。
  • は、効率的かつ一貫性のある方法で再利用できます。
  • は、[metadata] (メタデータ)を変更すると、そのメタデータを使用するすべてのジョブに変更がプロパゲートされるため、簡単に維持管理できます。

Talend Studioプロジェクトを作成

プロジェクトの作成は、Talend Studioを使用するための最初のステップです。プロジェクトによって仕事をよりよく整理できるようになります。

手順

  1. [Create a new project] (新しいプロジェクトを作成)を選択します。
  2. プロジェクトの名前を入力します。

    TalendDemo
  3. [Create] (作成)をクリックします。
  4. [Finish] (終了)をクリックします。

タスクの結果

プロジェクトが開きます。Talend Studioで作業する準備が整いました。

メタデータを使ってジョブを作成

Talend Studioプロジェクトにはジョブが含まれています。ジョブではコンポーネントを通じてワークフローのビルドが可能なので、特定のアクションを完了できます。

始める前に

[Integration] (統合)パースペクティブ([Window] (ウィンドウ) > パースペクティブ > [Integration] (統合))を選択します。

手順

  1. [Repository] (リポジトリー)で、[Job Designs] (ジョブデザイン)を右クリックします。
    1. [Create Standard Job] (標準ジョブを作成)をクリックします。
  2. [Name] (名前)フィールドに名前を入力します。

    useMetadata
  3. オプション: [Purpose] (目的)フィールドに目的を入力します。

    Display the use of Metadata in Talend Studio
  4. オプション: [Description] (説明)フィールドに説明を入力します。

    A simple job to demonstrate built-in properties vs. metadata
    ヒント: [Purpose] (目的)[Description] (説明)を入力して整理します。
  5. [Finish] (終了)をクリックします。

タスクの結果

[Designer] (デザイナー)で空のジョブが開かれます。

メタデータ設定

メタデータを設定することで、すべてのTalend Studioコンポーネントで再利用可能な情報を設定できます。

メタデータ定義を作成

メタデータ定義を作成すると、全コンポーネントで再利用可能な情報を設定できるようになります。

始める前に

  • このチュートリアルでは、.csvファイルを使用します。.csvファイルがない場合は、 [Downloads] (ダウンロード)タブをクリックしてcustomers_unordered.csvを保存します。

  • このチュートリアルでは他の区切り付きファイルも使用します。他の区切りファイルがない場合は、 [Downloads] (ダウンロード)タブをクリックしてdirectors.txtを保存します。

手順

  1. [Repository] (リポジトリー)[Metadata] (メタデータ)を展開し、[File delimited] (区切り付きファイル)を右クリックして、[Create file delimited] (区切り付きファイルを作成)をクリックします。
  2. [Name] (名前)フィールドに名前を入力します。

    Customers
  3. オプション: [Purpose] (目的)フィールドに目的を入力します。

    Creating reusable metadata thanks to a .csv file
  4. オプション: [Description] (説明)フィールドに説明を入力します。

    Reusable shareable customer metadata
    ヒント: [Purpose] (目的)[Description] (説明)を入力して整理します。
  5. [Next] (次へ)をクリックします。
    ウィザードの[Step 2] (ステップ2)に進みます。
  6. [Browse] (参照)をクリックし、[File Explorer] (ファイルエクスプローラー)で目的のファイルを選択します。
  7. [Next] (次へ)をクリックします。
    ウィザードの[Step 3] (ステップ3)に進みます。
  8. オプション: 解析の設定を定義します。

    • [File Settings] (ファイル設定)の下で[Field Separator] (フィールド区切り)を選択し、必要に応じて選択を変更します。
      注: 最も一般的な[Field Separator] (フィールド区切り) ; です。
    • [Preview] (プレビュー)の下で[Set heading row as column names] (見出し行をカラム名に設定)を選択します。[Header] (ヘッダー)フィールドに1という値が自動的に入力されます。これはファイルの1行目にファイルヘッダーがあることを意味します。
    ヒント: [Preview] (プレビュー)の下で[Refresh Preview] (プレビューを更新)をクリックすると、解析結果を確認します。
  9. [Next] (次へ)をクリックします。
    ウィザードの[Step 4] (ステップ4)に進みます。
  10. オプション: [Name] (名前)フィールドに名前を入力します。

    customersSchema
  11. オプション: サンプルファイルと同じ構造になるよう、[Schema] (スキーマ)をアップデートします。

    [Number] (番号) [Type] (タイプ)[String] (文字列)に変更します。郵便番号には演算関数が含まれないようにしてください。
  12. [Finish] (終了)をクリックします。

タスクの結果

[Repository] (リポジトリー)[Metadata] (メタデータ)の下にあるご自分のメタデータを使用できます。

メタデータによってコンポーネントを設定

メタデータによってコンポーネントを設定すれば、定義済み情報を使ってコンポーネントを設定できるようになります。

始める前に

メタデータ定義を作成していること(メタデータ定義を作成をご覧ください)。

手順

  1. [Designer] (デザイナー)内をクリックします。
  2. tFileInputDelimitedコンポーネントを追加します。
    注: デフォルトでは、コンポーネントは[Built-in] (組み込み)パラメーターで設定されています。
  3. tFileInputDelimitedコンポーネントをダブルクリックします。
    1. [Property type] (プロパティタイプ)リストで[Repository] (リポジトリー)を選択します。
    2. [Repository] (リポジトリー)フィールドの横にある[...]ボタンをクリックします。
    3. [Metadata] (メタデータ) > [File delimited] (区切り付きファイル)の下で、メタデータ定義を選択します。

      Customers 0.1
      すべての[Component] (コンポーネント)フィールドにメタデータ情報が入力されます。これらのフィールドはグレーで表示されるようになります。これは、フィールドがコンポーネントではなくメタデータに属していることを示します。

タスクの結果

コンポーネントがメタデータによって正しく設定されました。

データベースからメタデータ定義を作成

Talend Studioでは、既存のリソースを活用するよう、データベースからメタデータ定義を取得できます。

始める前に

このチュートリアルではデータベースを使用します。データベースがない場合は、 [Downloads] (ダウンロード)タブをクリックしてcustomers_unordered.sqlを保存します。データベースを互換性があるプログラムにインポートする必要があります。

手順

  1. [Repository] (リポジトリー)[Metadata] (メタデータ)を展開し、[Connections] (接続)を右クリックして、[Create Connection] (接続を作成)をクリックします。
    ウィザードの[Step 1] (ステップ1)に進みます。
  2. [Name] (名前)フィールドに名前を入力します。

    MySQL
  3. オプション: [Purpose] (目的)フィールドに目的を入力します。

    Demonstrate how to fetch metadata from a database
  4. オプション: [Description] (説明)フィールドに説明を入力します。

    Fetching CSV data imported into a MySQL database
    ヒント: [Purpose] (目的)[Description] (説明)を入力して整理します。
  5. [Next] (次へ)をクリックします。
    ウィザードの[Step 2] (ステップ2)に進みます。
  6. 接続情報を入力します。
    ヒント: [Test connection] (テスト接続)をクリックして、データベースへの接続をチェックします。
  7. [Finish] (終了)をクリックします。
    [Designer] (デザイナー)に進みます。
  8. [Repository] (リポジトリー)でメタデータを右クリックします。
    1. [Retrieve schema] (スキーマを取得)をクリックします。
      [Filter for the Table] (テーブル用フィルター)ウィンドウが表示されます。
    2. [Next] (次へ)をクリックします。
      [Add a Schema on repository] (スキーマをリポジトリーに追加)ウィンドウが表示されます。
    3. テーブル名の横にあるチェックボックスをオンにします。
    4. [Next] (次へ)をクリックします。
      データベーススキーマが表示されます。
    5. オプション: [Schema] (スキーマ)パラメーターを変更します。
    6. [Finish] (終了)をクリックします。

タスクの結果

テーブルスキーマがすべてメタデータとしてインポートされ、コンポーネントで再利用できるようになります。

メタデータを使ってデータベースを読み取って結果を表示

Talend Studioでデータベースを読み取って管理することで、データ管理ワークフローにデータベースを統合できるようになります。

始める前に

  • このチュートリアルではデータベースを使用します。データベースがない場合は、 [Downloads] (ダウンロード)タブをクリックしてcustomers_unordered.sqlを保存します。データベースを互換性があるプログラムにインポートする必要があります。

  • データベースからメタデータ定義を作成する必要があります(データベースからメタデータ定義を作成をご覧ください)。

手順

  1. [Repository] (リポジトリー)で、[Metadata] (メタデータ) > [Db Connections] (DB接続)の順に展開します。
  2. データベースのメタデータを[Designer] (デザイナー)上にドラッグ&ドロップします。
    1. tDBInputコンポーネントを選択します。
      コンポーネントはデータベーススキーマを継承します。
  3. [Designer] (デザイナー)tLogRowコンポーネントを追加します。
  4. tDBInputコンポーネントを右クリックします。
    1. [Row] (行) > [Main] (メイン)を選択します。
    2. tLogRowコンポーネントをクリックし、2つのコンポーネントをリンクします。
  5. オプション: tLogRowコンポーネントで、[Table] (テーブル) [Mode] (モード)を選択します。
  6. [Run] (実行)ビューで[Run] (実行)をクリックします。

タスクの結果

メタデータによって設定されたtDBInputコンポーネントがデータベースを読み取って、tLogRowコンポーネントがその内容をコンソール上に表示させます。