互換性があるJava環境 - 7.3

Mac 版 Talend Open Studio for Big Data インストール&アップグレードガイド

Version
7.3
Language
日本語 (日本)
EnrichDitaval
Open Studio for Big Data for Mac
Product
Talend Open Studio for Big Data
Module
Talend Studio
Content
インストールとアップグレード

次のテーブルは、Talend製品使用のためにダウンロードしてインストールするJavaの推奨環境をまとめたものです。

Compiler Compliance Levelは、ジョブコード生成に使用されるJavaバージョンに対応します。このオプションは、Studio環境設定で変更できます。詳細は、コンパイラーのコンプライアンスレベルの設定をご覧ください。

注: Talend製品および関連するサードパーティアプリケーション(Hadoopクラスターなど)はすべて、コンプライアンスの理由から同じJavaバージョンを使用する必要があります。Talendでは、関連するサードパーティアプリケーションをインストールまたはアップグレードする前に、 サポートされているJavaバージョンを確認することをお勧めしています。

次のようなサポートタイプがあります。

  • 推奨: 経験とカスタマー事例に基づいてTalendにより推奨される環境を示します。
  • サポート: リストされているコンポーネントまたはサービスの使用においてサポートされる環境を示します。
  • 制限付きサポート: メモで説明されている特定の条件付きでTalendによってサポートされる環境を示します。

StudioのJava環境

Talend Studioと互換性があるJava環境
Javaプラットフォーム Javaバージョン 1 サポートタイプ
OpenJDK (推奨されるディストリビューション: Zulu) 11 推奨
8 サポート
Oracle JDK 11 推奨
8 サポート

1 Oracle 8の実行時は、StudioはJDKコンパイラーのコンプライアンスレベル1.8 (デフォルト)に準拠する必要があります。インストールされているJDKのバージョンが1.8.0_161未満の場合は、追加リソースであるJava Cryptography Extension (JCE)無制限強度管轄ポリシーファイルインストールする必要があります。これはスタンドアロンジョブの実行にも適用できます。