TPS-5054 (cumulative patch) - 8.0

Version
8.0
Language
English (United States)
Product
Talend Big Data
Talend Big Data Platform
Talend Data Fabric
Talend Data Integration
Talend Data Management Platform
Talend Data Services Platform
Talend ESB
Talend MDM Platform
Talend Real-Time Big Data Platform
Module
Talend Identity and Access Management

TPS-5054 (cumulative patch)

Info Value
Patch Name Patch_20211216_TPS-5054_v1
Release Date 2021-12-16
Target Verson 20211216_1-V8.0.1
Product affected IAM

Introduction

This patch is cumulative. It includes all previous generally available patches for Talend IAM 8.0.1.

NOTE: For information on how to obtain this patch, reach out to your Support contact at Talend.

Fixed issues

This patch contains the following fixes:

  • TPS-5054: [8.0.1] Patch log4j CVE in Syncope

Prerequisites

Consider the following requirements for your system:

  • Talend IAM 8.0.1 must be installed.

Installation

  1. Stop IAM
  2. Create a backup directory
    $ mkdir -p <backup_dir>
    
  3. Copy original *.war files to the backup directory
    $ cp <TALEND>/iam/apache-tomcat/webapps/syncope.war <backup_dir>
    $ cp <TALEND>/iam/apache-tomcat/webapps/syncope-console.war <backup_dir>
    $ cp <TALEND>/iam/apache-tomcat/webapps/syncope-enduser.war <backup_dir>
    
    Note: if you made any changes in extracted service app before don't forget to backup them too.
  4. Remove original webapp directories and files
    $ rm -rf <TALEND>/iam/apache-tomcat/webapps/syncope*
    
  5. Uzip the patch file:
    $ unzip Patch_20211216_TPS-5054_v1.zip
    
  6. Copy patched war file to webapps directory replacing the original one
    $ cp *.war <TALEND>/iam/apache-tomcat/webapps/
    
  7. Start IAM

Uninstallation

  1. Stop IAM
  2. Remove patched webapp directories and files
    $ rm -rf <TALEND>/iam/apache-tomcat/webapps/syncope*
    
  3. Copy saved *.war files from the backup directory
    $ cp <backup_dir>/*.war <TALEND>/iam/apache-tomcat/webapps/
    
  4. Start IAM

Affected files for this patch

The following files are installed by this patch: - syncope.war - syncope-console.war - syncope-enduser.war