Talend Installer:已知问题和已知限制 - 7.2

Talend Master Data Management 产品发布说明

Version
7.2
Language
中文(简体)
EnrichDitaval
MDM
Product
Talend MDM Platform
Content
数据治理
版本说明

问题

变通方法

产品

Talend Administration CenterTalend JobServer 安装在相同的主机上时,许可证无法加载到 Talend Administration Center 中。 在首次登录到 Talend Administration Center 期间导入许可。

Talend MDM Platform

嵌入到安装程序的 MongoDB 不支持安全/SSL 配置模式。 要将具有安全连接的平台与 MongoDB 一同安装,请安装支持此功能的 MongoDB 版本,并连接到此外部 MongoDB 实例执行安装。

Talend MDM Platform

Talend Tools Installer/Talend Studio Installer 无法对 Windows 证书签名。

运行 Talend Tools Installer/Talend Studio Installer 时,可能会显示 Windows protected your PC (Windows 已保护你的电脑) 提示。

要继续安装,请在系统提示时单击 Run anyway (仍要运行)

Talend MDM Platform

在手动安装 Talend Log Server 时,使用 7-Zip 为 Talend-LogServer-VA.B.C-x86_64.zip 解压缩不起作用,未将所有文件解压缩。
在启动 Talend Log Server 时,一些文件缺失,导致出现以下异常:
[2018-04-04T12:12:58,629][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: plugins directory [D:\Talend\V701_20180403_GAA\logserv\elasticsearch-6.1.2\plugins] not found
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-6.1.2.jar:6.1.2]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-6.1.2.jar:6.1.2]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-6.1.2.jar:6.1.2]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-6.1.2.jar:6.1.2]
        at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-6.1.2.jar:6.1.2]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-6.1.2.jar:6.1.2]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:85) ~[elasticsearch-6.1.2.jar:6.1.2]
Caused by: java.lang.IllegalStateException: plugins directory [D:\Talend\V701_20180403_GAA\logserv\elasticsearch-6.1.2\plugins] not found
        at org.elasticsearch.bootstrap.Spawner.spawnNativePluginControllers(Spawner.java:69) ~[elasticsearch-6.1.2.jar:6.1.2]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:166) ~[elasticsearch-6.1.2.jar:6.1.2]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:322) ~[elasticsearch-6.1.2.jar:6.1.2]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) ~[elasticsearch-6.1.2.jar:6.1.2]
        ... 6 more

D:\Talend\V701_20180403_GAA\logserv>
要预防此问题,请使用标准 Windows“解压缩”工具。

Talend MDM Platform

Linux 上使用 Open JDK 11 无法安装 Nexus。 有两种替代方法:
  • 使用 Open JDK 8。
  • 禁止 Nexus 的安装:
    • 图形界面的安装模式下,在 Talend Administration Center Option (选项) 页面清除 Nexus 复选框。
    • 静默安装模式下,在 option 文件中将 tacInstallNexus 的值设为 0tacInstallNexus=0

Talend MDM Platform