Versions des distributions de plateformes supportées pour les Jobs Talend avec Big Data - 7.3

Guide d'installation de Talend MDM Platform pour Linux

EnrichVersion
7.3
EnrichProdName
Talend MDM Platform
task
Installation et mise à niveau
EnrichPlatform
Studio Talend
Talend Activity Monitoring Console
Talend Administration Center
Talend Artifact Repository
Talend CommandLine
Talend Data Preparation
Talend Data Stewardship
Talend DQ Portal
Talend ESB
Talend Identity and Access Management
Talend Installer
Talend JobServer
Talend Log Server
Talend MDM Server
Talend MDM Web UI
Talend Repository Manager
Talend Runtime
Talend SAP RFC Server

Distributions Hadoop communes et support dynamique des distributions Hadoop

Pour connaître la compatibilité entre les distributions communes d'Hadoop et les éléments Big Data supportés par Talend, cliquez sur un élément Big Data ci-dessous.

Les anciennes versions des plateformes Big Data supportées ne sont plus supportées par leurs vendeurs. Talend ne supporte plus une version une fois que celle-ci atteint sa date de fin de support prévue par le vendeur.

Talend et sa communauté vous fournissent la possibilité de continuer à utiliser une version qu'un vendeur ne supporte plus, dans les produits Talend. Ainsi, cette version peut être listée dans les tables suivantes et disponible dans les produits, mais Talend ne fournit plus de support pour cette version.

Talend supporte les versions mineures des versions des distributions listées dans les tableaux suivants.

Distributions Hadoop supportées avec HBase
Distribution Hadoop Version Supporte Kerberos Kinit et Keytab
HDP v2.5.0 Oui
v2.6.0 Oui
v2.6.0.3-8 Oui
v3.14.12-1 Oui

Les autres versions 3.x - compatibles via les distributions dynamiques

-
Cloudera 5.5 (mode YARN) Oui
5.6 (mode YARN) Oui
5.7 (mode YARN) Oui
5.8 (mode YARN) Oui
5.10 (mode YARN) Oui
5.12.1 (mode YARN) Oui
5.13.0 Oui

Les autres versions 5.x - compatibles via les distributions dynamiques

-

6.1.1

Oui

Les autres versions 6.x - compatibles via les distributions dynamiques

-
7.1.1 Oui
MapR 1, 2 5.0.0 (mode YARN) Oui
5.1.0 (mode YARN) Oui
5.2.0 (mode YARN) Oui

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

Distributions Hadoop supportées avec HCatalog
Distribution Hadoop Version Supporte Kerberos Kinit et Keytab
HDP v2.5.0 Oui
v2.6.0 Oui
v2.6.0.3-8 Oui
v3.14.12-1 Oui

Les autres versions 3.x - compatibles via les distributions dynamiques

-
Cloudera 5.5 (mode YARN) Oui
5.6 (mode YARN) Oui
5.7 (mode YARN) Oui
5.8 (mode YARN) Oui
5.10 (mode YARN) Oui
5.12.1 (mode YARN) Oui
5.13.0 Oui

Les autres versions 5.x - compatibles via les distributions dynamiques

-

6.1.1

Oui

Les autres versions 6.x - compatibles via les distributions dynamiques

-
MapR 1, 2 5.0.0 (mode YARN) Oui
5.1.0 (mode YARN) Oui
5.2.0 (mode YARN) Oui
6.0.0 (mode YARN) Oui
6.0.1 MEP 5.0 (mode YARN) Oui
6.1 / MEP 6.1 Oui

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

Distributions Hadoop supportées avec HDFS
Distribution Hadoop Version Supporte Kerberos Kinit et Keytab
HDP v2.5.0 Oui
v2.6.0 Oui
v2.6.0.3-8 Oui
v3.14.12-1 Oui

Les autres versions 3.x - compatibles via les distributions dynamiques

-
Cloudera 5.5 (mode YARN) Oui
5.6 (mode YARN) Oui
5.7 (mode YARN) Oui
5.8 (mode YARN) Oui
5.10 (mode YARN) Oui
5.12.1 (mode YARN) Oui
5.13.0 Oui

Les autres versions 5.x - compatibles via les distributions dynamiques

-

6.1.1

Oui

Les autres versions 6.x - compatibles via les distributions dynamiques

-
MapR 1, 2 5.0.0 (mode YARN) Oui
5.1.0 (mode YARN) Oui
5.2.0 (mode YARN) Oui
6.0.0 (mode YARN) Oui
6.0.1 MEP 5.0 (mode YARN) Oui
6.1 / MEP 6.1 Oui

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

Distributions Hadoop supportées avec Hive
Distribution Hadoop Version Supporte Kerberos Kinit et Keytab
HDP v2.5.0 Oui
v2.6.0 Oui
v2.6.0.3-8 Oui
v3.14.12-1 Oui

Les autres versions 3.x - compatibles via les distributions dynamiques

-
Cloudera 5.5 (mode YARN) Oui
5.6 (mode YARN) Oui
5.7 (mode YARN) Oui
5.8 (mode YARN) Oui
5.10 (mode YARN) Oui
5.12.1 (mode YARN) Oui
5.13.0 Oui

Les autres versions 5.x - compatibles via les distributions dynamiques

-

6.1.1

Oui

Les autres versions 6.x - compatibles via les distributions dynamiques

-
MapR 1, 2 5.0.0 (mode YARN) Oui
5.1.0 (mode YARN) Oui
5.2.0 (mode YARN) Oui
6.0.0 (mode YARN) Oui
6.0.1 MEP 5.0 (mode YARN) Oui
6.1 / MEP 6.1 Oui
Remarque : La perspective Profiling ne supporte pas le mode de connexion Embedded sur les distributions Hive. Ce mode est disponible pour les développeurs Hadoop principalement à des fins de test. Le Studio peut ne pas s'exécuter correctement en mode Embedded.

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

Distributions Hadoop supportées avec Sqoop
Distribution Hadoop Version Supporte Kerberos Kinit et Keytab
HDP v2.5.0 Oui
v2.6.0 Oui
v2.6.0.3-8 Oui
v3.1.4.12-1 Oui

Les autres versions 3.x - compatibles via les distributions dynamiques

-
Cloudera 5.5 (mode YARN) Oui
5.6 (mode YARN) Oui
5.7 (mode YARN) Oui
5.8 (mode YARN) Oui
5.10 (mode YARN) Oui
5.12.1 (mode YARN) Oui
5.13.0 Oui

Les autres versions 5.x - compatibles via les distributions dynamiques

-

6.1.1

Oui

Les autres versions 6.x - compatibles via les distributions dynamiques

-
MapR 1, 2 5.0.0 (mode YARN) Oui
5.1.0 (mode YARN) Oui
5.2.0 (mode YARN) Oui
6.0.0 (mode YARN) Oui
6.0.1 MEP 5.0 (mode YARN) Oui
6.1 / MEP 6.1 Oui

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

Distributions Hadoop supportées avec Spark
Distribution Hadoop Version Fonctionne avec Spark Standalone Fonctionne avec Spark YARN Supporte Kerberos Kinit et Keytab
HDP v2.5.0 - v1.6 (Dépréciée) Oui (YARN uniquement)
v2.6.0 - v1.6 (Dépréciée) / v2.1 Oui (YARN uniquement)
v2.6.0.3-8 - v1.6 (Dépréciée) / v2.1 Oui (YARN uniquement)
v3.1.4.12-1 - v2.3 Oui (YARN uniquement)

Les autres versions 3.x - compatibles via les distributions dynamiques

- - -
Cloudera 5.5 (mode YARN) v1.5 (Dépréciée) v1.5 (Dépréciée) Oui (YARN uniquement)
5.6 (mode YARN) v1.5 (Dépréciée) v1.5 (Dépréciée) Oui (YARN uniquement)
5.7 (mode YARN) v1.6 (Dépréciée) v1.6 (Dépréciée) Oui (YARN uniquement)
5.8 (mode YARN) v1.6 (Dépréciée) v1.6 (Dépréciée) / v2.1 Oui (YARN uniquement)
5.10 (mode YARN) v1.6 (Dépréciée) / v2.1 v1.6 (Dépréciée) / v2.1 Oui (YARN uniquement)
5.12.1 (mode YARN) v2.2 v2.2 Oui (YARN uniquement)
5.13.0 v2.2 v2.2 Oui (YARN uniquement)

Les autres versions 5.x - compatibles via les distributions dynamiques

- - -
6.1.1 v2.4 v2.4 Oui (YARN uniquement)

Les autres versions 6.x - compatibles via les distributions dynamiques

- - -
MapR 1, 2 5.0.0 (mode YARN) v1.3 (Dépréciée) v1.3 (Dépréciée) Oui (YARN uniquement)
5.1.0 (mode YARN) v1.5 (Dépréciée) v1.5 (Dépréciée) Oui (YARN uniquement)
5.2.0 (mode YARN) v1.6 (Dépréciée) v1.6 (Dépréciée) Oui (YARN uniquement)
6.0.0 (mode YARN) v2.1 v2.1 Oui (YARN uniquement)
6.0.1 MEP 5.0 (mode YARN) v2.2 v2.2 Oui (YARN uniquement)
6.1 / MEP 6.1 v2.3 v2.3 Oui (YARN uniquement)

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

Distributions Hadoop supportées avec Azure Data Lake Storage Gen2 (ADLS Gen2)
Distribution Hadoop Version Fonctionne avec Spark Standalone Fonctionne avec Spark YARN Supporte Kerberos Kinit et Keytab
HDP v3.1.4.12-1 - v2.3 Oui (YARN uniquement)

Les autres versions 3.x - compatibles via les distributions dynamiques

- - -
Cloudera

6.1.1

v2.4 v2.4 Oui (YARN uniquement)

Les autres versions 6.x - compatibles via les distributions dynamiques

- - -

Si vous avez besoin de plus d'informations concernant les plateformes Big Data Cloud supportées par Talend avec ADLS Gen2, consultez la section nommée Versions des distributions des plateformes Cloud Big Data supportées pour les Jobs Talend de votre Guide d'installation.

Distributions Hadoop supportées avec Kafka dans des Jobs Spark Streaming
Distribution Hadoop Version Fonctionne avec Spark Standalone Fonctionne avec Spark YARN Supporte Kerberos Kinit et Keytab Versions de Kafka
HDP v2.5.0 - v1.6 (Dépréciée) Oui (YARN uniquement) v0.10
v2.6.0 - v1.6 (Dépréciée) / v2.1 Oui (YARN uniquement) v0.10
v2.6.0.3-8 - v1.6 (Dépréciée) / v2.1 Oui (YARN uniquement)

v1.x

v3.1.4.12-1 - v2.3 Oui (YARN uniquement)

v2.x

Les autres versions 3.x - compatibles via les distributions dynamiques

- - - -
Cloudera 5.5 (mode YARN) v1.5 (Dépréciée) v1.5 (Dépréciée) Oui (YARN uniquement) v0.10
5.6 (mode YARN) v1.5 (Dépréciée) v1.5 (Dépréciée) Oui (YARN uniquement) v0.10
5.7 (mode YARN) v1.6 (Dépréciée) v1.6 (Dépréciée) Oui (YARN uniquement) v0.10
5.8 (mode YARN) v1.6 (Dépréciée) v1.6 (Dépréciée) / v2.1 Oui (YARN uniquement) v0.10
5.10 (mode YARN) v1.6 (Dépréciée) / v2.1 v1.6 (Dépréciée) / v2.1 Oui (YARN uniquement) v0.10
5.12.1 (mode YARN) v2.2 v2.2 Oui (YARN uniquement) v0.10
5.13.0 v2.2 v2.2 Oui (YARN uniquement) v0.10

Les autres versions 5.x - compatibles via les distributions dynamiques

- - - -

6.1.1

v2.4 v2.4 Oui (YARN uniquement)

v2.x

Les autres versions 6.x - compatibles via les distributions dynamiques

- - - -
MapR 1, 2 5.0.0 (mode YARN) v1.3 (Dépréciée) v1.3 (Dépréciée) Oui (YARN uniquement) v0.10
5.1.0 (mode YARN) v1.5 (Dépréciée) v1.5 (Dépréciée) Oui (YARN uniquement) v0.10
5.2.0 (mode YARN) v1.6 (Dépréciée) v1.6 (Dépréciée) Oui (YARN uniquement) v0.10
6.0.0 (mode YARN) v2.1 v2.1 Oui (YARN uniquement) v0.10
6.0.1 MEP 5.0 (mode YARN) v2.2 v2.2 Oui (YARN uniquement) v0.10
6.1 / MEP 6.1 v2.3 v2.3 Oui (YARN uniquement)

v1.x

Distributions Hadoop supportées avec Impala
Distribution Hadoop Version Supporte Kerberos Kinit et Keytab
Cloudera

7.1.1

-