Compatible Operating Systems

Talend ESB Installation Guide for Solaris

EnrichVersion
6.3
EnrichProdName
Talend ESB
task
Installation and Upgrade

Note

In the following documentation:

  • recommended: designates an environment recommended by Talend based on our experiences and customer usage;

  • supported: designates a supported environment for use with the listed component or service;

  • supported with limitations: designates an environment that is supported by Talend but with certain conditions explained in notes.

These tables provide a summary of the supported Operating Systems.

Table 5. Talend Studio

Support type

Operating System (64-bit)

Recommended

Linux

Ubuntu 16.04 LTS

Windows

Microsoft Windows Professional 7

Supported

Linux

Ubuntu 14.04 LTS

Ubuntu 12.04 LTS

Red Hat Enterprise Linux Server/CentOS 7.3

Red Hat Enterprise Linux Server/CentOS 7.2

Red Hat Enterprise Linux Server/CentOS 7.1

Red Hat Enterprise Linux Server/CentOS 6.8

Red Hat Enterprise Linux Server/CentOS 6.7

Windows

Microsoft Windows 10

Microsoft Windows 8.1

Microsoft Windows Server 2012 R2 RTM

Mac

macOS 10.12 Sierra

OS X 10.11 El Capitan

OS X 10.10 Yosemite


Table 6. Talend server modules

Support type

Operating System

Processor

Recommended

Linux

Red Hat Enterprise Linux Server 7.3

64-bit

Windows

Microsoft Windows Server 2012 R2

64-bit

Supported

Linux

Ubuntu 16.04 LTS

64-bit

Ubuntu 14.04 LTS

64-bit

Ubuntu 12.04 LTS

64-bit

Red Hat Enterprise Linux Server/CentOS 7.2

64-bit

Red Hat Enterprise Linux Server/CentOS 7.1

64-bit

Red Hat Enterprise Linux Server/CentOS 6.8

64-bit

Red Hat Enterprise Linux Server/CentOS 6.7

64-bit

SUSE SLES 12

64-bit

SUSE SLES 11

64-bit

Unix

Solaris (SunOs) 11

x86/64-bit1

Solaris (SunOs) 11

Sparc/64-bit2

Solaris (SunOs) 103

x86/64-bit1

Solaris (SunOs) 103

Sparc/64-bit2

AIX 7.1

64-bit (IBM Java 8 only)4

Windows

Microsoft Windows Server 2016

64-bit

Microsoft Windows Server 2012

64-bit


1. Only supported for Talend Administration Center, CommandLine, JobServer, Talend ESB and Talend Runtime.

2. Only supported for Talend ESB and Talend Runtime.

3. At least patch level 9 should be installed.

4. Only supported for CommandLine, JobServer, Talend ESB and Talend Runtime.

The server modules include Artifact Repository, Talend Activity Monitoring Console, Talend Administration Center, Talend Data Preparation, Talend Data Stewardship, Talend ESB, Talend Log Server, Talend Repository Manager, Talend Runtime.

Note that Talend Metadata Bridge is only supported on Windows.