Java - 6.2

Talend Open Studio for Data Quality Installation and Upgrade Guide for Mac

EnrichVersion
6.2
EnrichProdName
Talend Open Studio for Data Quality
task
Installation and Upgrade
EnrichPlatform
Talend Studio

In order to use your Talend product, Java must be installed on your machine. If you install your Talend Studio using the Talend Studio Installer, you do not need to set up a Java Environment as it is embedded in the Installer.

These pages list:

Compatible Java environments

Note

In the following documentation:

  • recommended: designates an environment recommended by Talend based on our experiences and customer usage;

  • supported: designates a supported environment for use with the listed component or service;

  • supported with limitations: designates an environment that is supported by Talend but with certain conditions explained in notes.

The information contained in the following table is applicable for the 6.2.2 version of your Talend product at the time of its release. For updated information on the latest supported software or databases, see this page.

These tables provide a summary of the supported Java Runtime environments.

In this table:

  • (R) means that this combination is recommended;

  • means that this combination is supported;

  • means that this combination is not supported.

The Compiler Compliance Level corresponds to the Java version used for the Job code generation. This option can be changed in the Studio preferences. For more information, see Talend Studio User Guide.

Table 5. Studio Java environments

Support Type

JRE Version

Studio JDK Compiler Compliance Level

Recommended

Oracle 8

1.7 (default)

Supported

Oracle 8

1.8


Depending on the licence you have, the available Execution Servers may differ.

Table 6. Server Java environments

JRE Version

JobServer

MDM Server

ESB/Talend Runtime

ESB/Microservices

Big Data Distributions

Talend Server Applications1

Comment/Limitation

Oracle 7 (running alongside Oracle 8)

Compatible with Java 1.7 only

Compatible with Studio JDK Compiler Compliance Level 1.7 only

Oracle 8

(R)

(R)

(R)

(R)

Compatible with Java 1.8

(R)

Compatible with Studio JDK Compiler Compliance Level 1.7 (default/recommended) or 1.8


For example, the recommended combination is:

  • Oracle 8 installed on the machine running the Studio;

  • 1.7 set in the Compiler Compliance Level preferences of the Studio;

  • Oracle 8 installed on the machine(s) running the Execution Server(s) and the Talend Server Application(s);

  • Big Data Distributions compatible with Java 1.8 used.

For more information on Java specificities (version, Operating Systems compatibility), see the Knowledge Base articles on Talend Help Center.

Setting up JAVA_HOME

In order for your Talend product to use the Java environment installed on your machine, you must set the JAVA_HOME environment variable.

To do so, proceed as follows:

  1. Find the folder where Java is installed, usually /Library/Java/Home.

  2. Open a terminal.

  3. Use the export command to set the JAVA_HOME and Path variables.

    For example:

    export JAVA_HOME=/usr/lib/jvm/jre1.8.0_65
    export PATH=$JAVA_HOME/bin:$PATH
  4. Add these lines at the end of the global profiles in the /etc/profile file or in the user profiles in the ~/.profile file.

    After changing one of these files you have to log on again.