Environnements Java compatibles - 7.0

Guide d'installation et de migration de Talend Open Studio for ESB pour Linux

EnrichVersion
7.0
EnrichProdName
Talend Open Studio for ESB
task
Installation et mise à niveau
EnrichPlatform
Studio Talend
Talend ESB
Talend Runtime

Les tableaux suivants fournissent des informations sur l'environnement Java que vous devez télécharger et installer pour utiliser votre produit Talend.

Le niveau de conformité du compilateur (Compiler Compliance Level) correspond à la version de Java utilisée pour la génération de code des Jobs. Cette option peut être changée dans les préférences du Studio. Pour plus d'informations, consultez le Guide utilisateur du Studio Talend.

Remarque : Tous les produits Talend et leurs applications tierces associées, comme le cluster Hadoop, doivent utiliser la même version de Java pour des raisons de compatibilité. Avant d'installer ou de mettre à niveau toute application tierce associée, Talend vous recommande de vérifier la version Java supportée.

Dans la documentation suivante :

  • recommandé : désigne un environnement recommandé par Talend sur la base de l'utilisation et client ;

  • supporté : désigne un environnement supporté pour une utilisation avec les composants ou services listés ;

  • supporté avec limitations : désigne un environnement qui est supporté par Talend sous certaines conditions détaillées dans des notes.

Environnements Java pour le Studio

Type de support Version JRE Niveau de conformité du compilateur JDK du Studio (Compiler Compliance Level)
Recommandé Oracle 8 1.8 (par défaut)

Environnements Java pour les serveurs

Les modules serveurs comprennent :

  • Talend ESB Servers
  • Talend Runtime
Version JRE Talend JobServer Talend MDM Server Talend ESB/Talend Runtime Talend ESB/Microservices Distributions Big Data Serveur d'application Talend Commentaire/Limitation
Oracle 8 (R) (R) (R) (R) Compatible avec Java 1.8 (R) Compatible avec le niveau de conformité du compilateur JDK du Studio (Compiler Compliance Level) défini sur 1.7 (par défaut et recommandé) ou 1.8