Quand installer des modules externes ? - 7.3

Guide d'installation et de migration de Talend Open Studio for Data Quality pour Linux

EnrichVersion
7.3
EnrichProdName
Talend Open Studio for Data Quality
task
Installation et mise à niveau
EnrichPlatform
Studio Talend

Votre Studio Talend vous indique quand vous avez besoin d'installer des modules externes et vous indique quels sont les modules à installer.

Votre Studio Talend vous notifie de plusieurs manières au sujet des modules externes requis.

  • L'assistant Additional Talend packages s'ouvre lorsque vous démarrez votre Studio Talend, si des packages supplémentaires, y compris des modules externes, doivent être installés pour que les fonctionnalités du Studio fonctionnent.

    Conseil : L'assistant Additional Talend packages s'ouvre également lorsque vous sélectionnez Help > Install Additional Packages dans le menu du Studio.
  • Dans votre espace de modélisation graphique, si un composant nécessite l'installation de modules externes afin de pouvoir fonctionner correctement, un indicateur d'erreur rouge apparaît sur le composant. En déplaçant le pointeur de votre souris sur cet indicateur d'erreur, vous pouvez voir une info-bulle qui vous indique quels modules externes sont requis pour faire fonctionner ce composant.
  • Lorsque vous ouvrez la vue Basic settings ou Advanced settings d'un composant pour lequel un ou plusieurs modules externes sont requis, des informations surlignées concernant les modules externes s'affichent, suivies d'un bouton Install. Cliquer sur ce bouton Install permet d'ouvrir un assistant qui affiche les modules externes à installer.
  • La vue Modules liste tous les modules requis pour que le Studio fonctionne proprement, y compris les bibliothèques Java et les pilotes que vous devez installer.

    Si la vue Modules ne s'affiche pas sous votre espace de modélisation graphique, cliquez sur Window > Show View... > Talend puis sélectionnez Modules dans la liste.

    Dans cette vue :

    Élément Description
    Filter text field Vous permet de rechercher des modules externes en se basant sur le statut, contexte, nom de fichier du module et URI Maven.
    Statut Indique si un module est installé ou non sur votre système.

    L'icône indique que le module n'est pas obligatoire pour le composant correspondant ou la métadonnée de connexion listé(e) dans cette colonne.

    L'icône indique que le module est absolument nécessaire pour le composant ou la métadonnée de connexion correspondant.

    Context Donne le nom du composant ou de la métadonnée de connexion utilisant le module. Si cette colonne est vide, le module est requis pour l'utilisation générale de votre Studio Talend.
    Module Donne le nom exact du module.
    Maven URI Identifie de manière unique le déploiement du module dans Maven.

    Vous pouvez personnaliser l'URI Maven d'un module en cliquant sur le champ Maven URI puis sur le bouton [...] qui s'ouvre. Pour plus d'informations, consultez Personnaliser l'URI de Maven pour le déploiement de modules externes.

    Actualise cette vue afin de refléter le statut le plus récent des modules.

    Dans le cas d'un travail collaboratif, une fois qu'un module requis est installé dans le Studio d'une personne, les autres peuvent simplement actualiser leur vue Modules pour ajouter ce module à leur Studio Talend.

    Importe les paramètres Maven personnalisés depuis un fichier local.
    Exporte les paramètres Maven personnalisés dans un fichier local.
    Vous permet d'installer dans votre Studio un module externe déjà téléchargé. Pour plus de détails, consultez Installation manuelle de modules externes via la vue Modules.
    Ouvre l'assistant de téléchargement et installation des Jar, qui va lister tous les modules externes requis non intégrés dans le Studio Talend.
  • Un assistant d'installation du Jar s'ouvre lorsque vous :
    • déposez un composant de la Palette si un ou plusieurs modules externes requis pour que ce composant fonctionne manquent dans le Studio.
    • cliquez sur le bouton Check dans un assistant de configuration d'une métadonnée de connexion dans le Studio si un ou plusieurs modules externes requis pour la connexion manquent dans le Studio.
    • cliquez sur le bouton Guess schema dans la vue Component d'un composant si un ou plusieurs module(s) externe(s) requis pour que le composant fonctionnent manque(nt) dans le Studio.
    • cliquez sur Install en haut de la vue Basic settings ou Advanced settings d'un composant pour lequel un ou plusieurs module(s) externe(s) requis manque(nt).
    • exécutez un Job contenant des composants ou des métadonnées de connexion pour lesquels un ou plusieurs module(s) externe(s) requis manque(nt).
    • sélectionnez un ou plusieurs module(s) non intégré(s) dans le Studio et cliquez sur le bouton dans la vue Modules.

    Cet assistant :

    • liste les modules externes à installer et les licences sous lesquels ils sont fournis,
    • fournit les URI Maven par défaut identifiant ke déploiement des modules,
    • fournit l'accès aux sites Web officiels à partir desquels vous pouvez obtenir plus d'informations sur les modules,
    • vous permet de télécharger et d'installer automatiquement tous les modules disponibles dans le référentiel Talend,
    • vous permet d'installer les modules non disponibles dans le référentiel Talend manuellement.

    Lorsque vous déposez un composant, configurez une connexion ou récupérez le schéma d'une base de données qui requiert un module externe pour lequel ni le fichier Jar ni l'URL de téléchargement ne sont disponibles sur le site Web de Talend, l'assistant d'installation des fichiers Jar ne s'affiche pas, mais la vue Error Log affiche un message d'erreur vous informant que l'URL de téléchargement de ce module n'est pas disponible. Vous pouvez chercher et télécharger par vous-même, puis installer manuellement le module dans le Studio.

    Conseil : Pour afficher la vue Error Log dans les onglets, cliquez sur Window > Show views depuis le menu, puis développez le nœud General et sélectionnez Error Log.