Versions des distributions de plateformes supportées pour les Jobs Talend avec Big Data - 7.2

Guide d'installation de Talend Big Data Platform pour Mac

EnrichVersion
7.2
EnrichProdName
Talend Big Data Platform
task
Installation et mise à niveau
EnrichPlatform
Studio Talend
Talend Activity Monitoring Console
Talend Administration Center
Talend Artifact Repository
Talend CommandLine
Talend Data Preparation
Talend Data Stewardship
Talend DQ Portal
Talend Identity and Access Management
Talend Installer
Talend JobServer
Talend Log Server
Talend Repository Manager
Talend Runtime
Talend SAP RFC Server

Distributions communes d'Hadoop

Pour connaître la compatibilité entre les distributions communes d'Hadoop et les plateformes de Big Data supportées par Talend, cliquez sur une plateforme Big Data ci-dessous.

Distributions Hadoop supportées avec HBase
Distribution Hadoop Version Fonctionne avec HBase Supporte Kerberos Kinit et Keytab
HDP v2.4.0 Oui Oui
v2.5.0 Oui Oui
v2.6.0 Oui Oui
v2.6.0.3-8 Oui Oui
Cloudera 5.5 (mode YARN) Oui Oui
5.6 (mode YARN) Oui Oui
5.7 (mode YARN) Oui Oui
5.8 (mode YARN) Oui Oui
5.10 (mode YARN) Oui Oui
5.12.1 (mode YARN) Oui Oui
5.13.0 Oui Oui
6.1.1 Oui Oui
MapR 1, 2 5.0.0 (mode YARN) Oui Oui
5.1.0 (mode YARN) Oui Oui
5.2.0 (mode YARN) Oui Oui
6.0.0 (mode YARN)    
6.0.1 MEP 5.0 (mode YARN)    
6.1 / MEP 6.1    
Amazon EMR3 4.5.0 (Apache 2.7.2)    
4.6.0 (Apache 2.7.2) Oui  
5.0.0 (Apache 2.7.2) Oui  
5.5.0 (Apache 2.7.2) Oui  
5.8.0 (Apache 2.7.2) Oui  
5.15.0 (Hadoop 2.8.3).0 (Apache 2.7.2) Oui  

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

3. Les versions d'Amazon EMR supportées par le composant tAmazonEMRManage sont les versions 4.0.0, 4.1.0, 4.2.0, 4.5.0, 4.6.0, 4.9.2 et 5.11.0.

Distributions Hadoop supportées avec HCatalog
Distribution Hadoop Version Fonctionne avec HCatalog Supporte Kerberos Kinit et Keytab
HDP v2.4.0 Oui Oui
v2.5.0 Oui Oui
v2.6.0 Oui Oui
v2.6.0.3-8 Oui Oui
Cloudera 5.5 (mode YARN) Oui Oui
5.6 (mode YARN) Oui Oui
5.7 (mode YARN) Oui Oui
5.8 (mode YARN) Oui Oui
5.10 (mode YARN) Oui Oui
5.12.1 (mode YARN) Oui Oui
5.13.0 Oui Oui
6.1.1 Oui Oui
MapR 1, 2 5.0.0 (mode YARN) Oui Oui
5.1.0 (mode YARN) Oui Oui
5.2.0 (mode YARN) Oui Oui
6.0.0 (mode YARN) Oui Oui
6.0.1 MEP 5.0 (mode YARN) Oui Oui
6.1 / MEP 6.1 Oui Oui
Amazon EMR 3 4.5.0 (Apache 2.7.2) Oui Oui
4.6.0 (Apache 2.7.2) Oui Oui
5.0.0 (Apache 2.7.2) Oui Oui
5.5.0 (Apache 2.7.2) Oui Oui
5.8.0 (Apache 2.7.2) Oui Oui
5.15.0 (Hadoop 2.8.3).0 (Apache 2.7.2) Oui Oui

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

3. Les versions d'Amazon EMR supportées par le composant tAmazonEMRManage sont les versions 4.0.0, 4.1.0, 4.2.0, 4.5.0, 4.6.0, 4.9.2 et 5.11.0.

Distributions Hadoop supportées avec HDFS
Distribution Hadoop Version Fonctionne avec HDFS Supporte Kerberos Kinit et Keytab
HDP v2.4.0 Oui Oui
v2.5.0 Oui Oui
v2.6.0 Oui Oui
v2.6.0.3-8 Oui Oui
Cloudera 5.5 (mode YARN) Oui Oui
5.6 (mode YARN) Oui Oui
5.7 (mode YARN) Oui Oui
5.8 (mode YARN) Oui Oui
5.10 (mode YARN) Oui Oui
5.12.1 (mode YARN) Oui Oui
5.13.0 Oui Oui
6.1.1 Oui Oui
MapR 1, 2 5.0.0 (mode YARN) Oui Oui
5.1.0 (mode YARN) Oui Oui
5.2.0 (mode YARN) Oui Oui
6.0.0 (mode YARN) Oui Oui
6.0.1 MEP 5.0 (mode YARN) Oui Oui
6.1 / MEP 6.1 Oui Oui
Amazon EMR 3 4.5.0 (Apache 2.7.2) Oui  
4.6.0 (Apache 2.7.2) Oui  
5.0.0 (Apache 2.7.2) Oui  
5.5.0 (Apache 2.7.2) Oui  
5.8.0 (Apache 2.7.2) Oui  
5.15.0 (Hadoop 2.8.3).0 (Apache 2.7.2) Oui  

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

3. Les versions d'Amazon EMR supportées par le composant tAmazonEMRManage sont les versions 4.0.0, 4.1.0, 4.2.0, 4.5.0, 4.6.0, 4.9.2 et 5.11.0.

Distributions Hadoop supportées avec Hive
Distribution Hadoop Version Fonctionne avec Hive Supporte Kerberos Kinit et Keytab
HDP v2.4.0 Oui Oui
v2.5.0 Oui Oui
v2.6.0 Oui Oui
v2.6.0.3-8 Oui Oui
Cloudera 5.5 (mode YARN) Oui Oui
5.6 (mode YARN) Oui Oui
5.7 (mode YARN) Oui Oui
5.8 (mode YARN) Oui Oui
5.10 (mode YARN) Oui Oui
5.12.1 (mode YARN) Oui Oui
5.13.0 Oui Oui
6.1.1 Oui Oui
MapR 1, 2 5.0.0 (mode YARN) Oui Oui
5.1.0 (mode YARN) Oui Oui
5.2.0 (mode YARN) Oui Oui
6.0.0 (mode YARN) Oui Oui
6.0.1 MEP 5.0 (mode YARN) Oui Oui
6.1 / MEP 6.1 Oui Oui
Amazon EMR 3 4.5.0 (Apache 2.7.2) Oui  
4.6.0 (Apache 2.7.2) Oui  
5.0.0 (Apache 2.7.2) Oui  
5.5.0 (Apache 2.7.2) Oui  
5.8.0 (Apache 2.7.2) Oui  
5.15.0 (Hadoop 2.8.3).0 (Apache 2.7.2) Oui  
Remarque : La perspective Profiling ne supporte pas le mode de connexion Embedded sur les distributions Hive. Ce mode est disponible pour les développeurs Hadoop principalement à des fins de test. Le Studio peut ne pas s'exécuter correctement en mode Embedded.

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

3. Les versions d'Amazon EMR supportées par le composant tAmazonEMRManage sont les versions 4.0.0, 4.1.0, 4.2.0, 4.5.0, 4.6.0, 4.9.2 et 5.11.0.

Distributions Hadoop supportées avec Oozie
Distribution Hadoop Version Fonctionne avec Hive Supporte Kerberos Kinit et Keytab
HDP v2.4.0 Oui Oui
v2.5.0 Oui Oui
v2.6.0 Oui Oui
v2.6.0.3-8    
Cloudera 5.5 (mode YARN) Oui Oui
5.6 (mode YARN) Oui Oui
5.7 (mode YARN) Oui Oui
5.8 (mode YARN) Oui Oui
5.10 (mode YARN) Oui Oui
5.12.1 (mode YARN) Oui Oui
5.13.0 Oui Oui
6.1.1    
MapR 1, 2 5.0.0 (mode YARN) Oui Oui
5.1.0 (mode YARN) Oui Oui
5.2.0 (mode YARN) Oui Oui
6.0.0 (mode YARN) Oui Oui
6.0.1 MEP 5.0 (mode YARN) Oui Oui
6.1 / MEP 6.1    
Amazon EMR3 4.5.0 (Apache 2.7.2) Oui  
4.6.0 (Apache 2.7.2) Oui  
5.0.0 (Apache 2.7.2) Oui  
5.5.0 (Apache 2.7.2) Oui  
5.8.0 (Apache 2.7.2) Oui  
5.15.0 (Hadoop 2.8.3).0 (Apache 2.7.2) Oui  

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

3. Les versions d'Amazon EMR supportées par le composant tAmazonEMRManage sont les versions 4.0.0, 4.1.0, 4.2.0, 4.5.0, 4.6.0, 4.9.2 et 5.11.0.

Distributions Hadoop supportées avec Pig
Distribution Hadoop Version Fonctionne avec Pig Supporte Kerberos Kinit et Keytab
HDP v2.4.0 Oui Oui
v2.5.0 Oui Oui
v2.6.0 Oui Oui
v2.6.0.3-8 Oui Oui
Cloudera 5.5 (mode YARN) Oui Oui
5.6 (mode YARN) Oui Oui
5.7 (mode YARN) Oui Oui
5.8 (mode YARN) Oui Oui
5.10 (mode YARN) Oui Oui
5.12.1 (mode YARN) Oui Oui
5.13.0 Oui Oui
6.1.1 Oui Oui
MapR 1, 2 5.0.0 (mode YARN) Oui Oui
5.1.0 (mode YARN) Oui Oui
5.2.0 (mode YARN) Oui Oui
6.0.0 (mode YARN) Oui Oui
6.0.1 MEP 5.0 (mode YARN) Oui Oui
6.1 / MEP 6.1 Oui Oui
Amazon EMR 3 4.5.0 (Apache 2.7.2) Oui  
4.6.0 (Apache 2.7.2) Oui  
5.0.0 (Apache 2.7.2) Oui  
5.5.0 (Apache 2.7.2) Oui  
5.8.0 (Apache 2.7.2) Oui  
5.15.0 (Hadoop 2.8.3).0 (Apache 2.7.2) Oui  

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

3. Les versions d'Amazon EMR supportées par le composant tAmazonEMRManage sont les versions 4.0.0, 4.1.0, 4.2.0, 4.5.0, 4.6.0, 4.9.2 et 5.11.0.

Distributions Hadoop supportées avec Sqoop
Distribution Hadoop Version Fonctionne avec Sqoop Supporte Kerberos Kinit et Keytab
HDP v2.4.0 Oui Oui
v2.5.0 Oui Oui
v2.6.0 Oui Oui
v2.6.0.3-8 Oui Oui
Cloudera 5.5 (mode YARN) Oui Oui
5.6 (mode YARN) Oui Oui
5.7 (mode YARN) Oui Oui
5.8 (mode YARN) Oui Oui
5.10 (mode YARN) Oui Oui
5.12.1 (mode YARN) Oui Oui
5.13.0 Oui Oui
6.1.1 Oui Oui
MapR 1, 2 5.0.0 (mode YARN) Oui Oui
5.1.0 (mode YARN) Oui Oui
5.2.0 (mode YARN) Oui Oui
6.0.0 (mode YARN) Oui Oui
6.0.1 MEP 5.0 (mode YARN) Oui Oui
6.1 / MEP 6.1 Oui Oui
Amazon EMR 3 4.5.0 (Apache 2.7.2) Oui  
4.6.0 (Apache 2.7.2) Oui  
5.0.0 (Apache 2.7.2) Oui  
5.5.0 (Apache 2.7.2) Oui  
5.8.0 (Apache 2.7.2) Oui  
5.15.0 (Hadoop 2.8.3).0 (Apache 2.7.2) Oui  

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

3. Les versions d'Amazon EMR supportées par le composant tAmazonEMRManage sont les versions 4.0.0, 4.1.0, 4.2.0, 4.5.0, 4.6.0, 4.9.2 et 5.11.0.

Distributions Hadoop supportées avec Talend MapReduce
Distribution Hadoop Version Fonctionne avec Talend MapReduce Supporte Kerberos Kinit et Keytab
HDP v2.4.0 Oui Oui
v2.5.0 Oui Oui
v2.6.0 Oui Oui
v2.6.0.3-8 Oui Oui
Cloudera 5.5 (mode YARN) Oui Oui
5.6 (mode YARN) Oui Oui
5.7 (mode YARN) Oui Oui
5.8 (mode YARN) Oui Oui
5.10 (mode YARN) Oui Oui
5.12.1 (mode YARN) Oui Oui
5.13.0 Oui Oui
6.1.1    
MapR 1, 2 5.0.0 (mode YARN) Oui Oui
5.1.0 (mode YARN) Oui Oui
5.2.0 (mode YARN) Oui Oui
6.0.0 (mode YARN) Oui Oui
6.0.1 MEP 5.0 (mode YARN) Oui Oui
Amazon EMR 3 4.5.0 (Apache 2.7.2) Oui  
4.6.0 (Apache 2.7.2) Oui  
5.0.0 (Apache 2.7.2) Oui  
5.5.0 (Apache 2.7.2) Oui  
5.8.0 (Apache 2.7.2) Oui  
5.15.0 (Hadoop 2.8.3).0 (Apache 2.7.2) Oui  

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

3. Les versions d'Amazon EMR supportées par le composant tAmazonEMRManage sont les versions 4.0.0, 4.1.0, 4.2.0, 4.5.0, 4.6.0, 4.9.2 et 5.11.0.

Distributions Hadoop supportées avec Spark
Distribution Hadoop Version Fonctionne avec Spark Standalone Fonctionne avec Spark YARN Supporte Kerberos Kinit et Keytab
HDP v2.4.0   v1.6 Oui (YARN uniquement)
v2.5.0   v1.6 Oui (YARN uniquement)
v2.6.0   v1.6 / v2.1 Oui (YARN uniquement)
v2.6.0.3-8   v1.6 / v2.1 Oui (YARN uniquement)
Cloudera 5.5 (mode YARN) v1.5 v1.5 Oui (YARN uniquement)
5.6 (mode YARN) v1.5 v1.5 Oui (YARN uniquement)
5.7 (mode YARN) v1.6 v1.6 Oui (YARN uniquement)
5.8 (mode YARN) v1.6 v1.6 / v2.1 Oui (YARN uniquement)
5.10 (mode YARN) v1.6 / 2.1 v1.6 / v2.1 Oui (YARN uniquement)
5.12.1 (mode YARN) v2.2 v2.2 Oui (YARN uniquement)
5.13.0 v2.2 v2.2 Oui (YARN uniquement)
6.1.1 v2.4 v2.4 Oui (YARN uniquement)
MapR 1, 2 5.0.0 (mode YARN) v1.3 v1.3 Oui (YARN uniquement)
5.1.0 (mode YARN) v1.5 v1.5 Oui (YARN uniquement)
5.2.0 (mode YARN) v1.6 v1.6 Oui (YARN uniquement)
6.0.0 (mode YARN) v2.1 v2.1 Oui (YARN uniquement)
6.0.1 MEP 5.0 (mode YARN) v2.2 v2.2 Oui (YARN uniquement)
6.1 / MEP 6.1 v2.3 v2.3 Oui (YARN uniquement)
Amazon EMR 3 4.5.0 (Apache 2.7.2)   v1.6  
4.6.0 (Apache 2.7.2)   v1.6  
5.0.0 (Apache 2.7.2)   v2.0  
5.5.0 (Apache 2.7.2)   v2.1  
5.8.0 (Apache 2.7.2)   v2.2  
5.15.0 (Hadoop 2.8.3).0 (Apache 2.7.2)   v2.3 Oui (YARN uniquement)

1. Pour toutes les versions de MapR antérieures à la version 6.0, le mécanisme de ticket de sécurité de MapR est supporté par le Studio.

2. MapR 6.0 ne supporte plus HBase, mais supporte à présent MapR-DB. Pour plus d'informations, consultez https://maprdocs.mapr.com/home/ReleaseNotes/install_upgrade_notes.html.

3. Les versions d'Amazon EMR supportées par le composant tAmazonEMRManage sont les versions 4.0.0, 4.1.0, 4.2.0, 4.5.0, 4.6.0, 4.9.2 et 5.11.0.