Upgrading Talend Artifact Repository - 7.1

Talend ESB Migration Guide

EnrichVersion
7.1
EnrichProdName
Talend ESB
task
Installation and Upgrade
EnrichPlatform
Talend Activity Monitoring Console
Talend Administration Center
Talend Artifact Repository
Talend CommandLine
Talend Data Preparation
Talend Data Stewardship
Talend ESB
Talend Identity and Access Management
Talend Log Server
Talend Runtime
Talend Studio

You need to upgrade your Nexus to the latest Nexus 2.x version as detailed in Upgrading from Nexus 2.x to the latest Nexus 2.x version available before starting the upgrade to Nexus 3 as detailed in Upgrading from Nexus 2.14.8 and beyond to Nexus 3.

For more information, see Sonatype's documentation: https://help.sonatype.com/repomanager3/upgrading.

The following section describes how to migrate from an existing Talend Artifact Repository instance to a Talend Artifact Repository version that is compatible with a Talend product version 7.x or higher while keeping your configuration settings and the artifacts you have previously published to the repository.

For more information on the Nexus repository and how to use it with the Talend products, see Compatible artifact repository.

The new Talend Artifact Repository configuration will be merged with your existing data at next start-up.

Note: Nexus 3, the version of Nexus shipped with Talend 7.x, is not supported by Publisher. To use Publisher, install Nexus 2 and configure Talend Administration Center to use the Nexus 2 instance.