Software requirements

Talend Data Integration Getting Started Guide

author
Talend Documentation Team
EnrichVersion
6.5
EnrichProdName
Talend Data Integration
task
Design and Development
Installation and Upgrade
To make the most out of your Talend product, please consider the following system and software requirements:

Required software

  • Operating System for Talend Studio:

    Support type Operating system (64 bits only)
    Recommended Ubuntu 16.04 LTS
    Recommended Microsoft Windows Professional 7
    Supported Apple macOS 10.13/High Sierra
    Apple macOS 10.12/Sierra
    Apple OS X 10.11/El Capitan
    Apple OS X 10.10/Yosemite
  • Operating System for Talend Server modules:

    Support type Operating system (64 bits only)
    Recommended Microsoft Windows Server 2012 R2
    Recommended Red Hat Enterprise Linux Server/CentOS 7.3
    Supported Ubuntu 17.04
    Ubuntu 16.04 LTS
    Ubuntu 14.04 LTS
    Ubuntu 12.04 LTS
  • Java 8 JRE Oracle. See Installing Java.

  • For Windows, VisualSVN Server. See Installing and configuring a versioning and revision control system on Windows.
  • A properly installed and configured MySQL database, with a database named gettingstarted.

Optional software