Utiliser les variables de contextes pour se connecter à la base de données des rapports - 6.1

Talend Data Services Platform Studio Guide utilisateur

EnrichVersion
6.1
EnrichProdName
Talend Data Services Platform
task
Création et développement
Qualité et préparation de données
EnrichPlatform
Studio Talend

Vous pouvez définir des paramètres de contexte et les utiliser pour exécuter des rapports de qualité de données dans différentes configurations, Prod et Test par exemple.Vous pouvez effectuer et valider plusieurs étapes de test avant de décider qu'un groupe de rapports est prêt à aller en production.

Le Studio Talend vous offre la possibilité de créer plusieurs contextes d'ensembles de données. Vous pouvez créer des contextes d'ensembles de données en une seule fois à partir de la fenêtre [Preferences] du Studio ou créer des contextes d'ensembles de données à partir du nœud Contexts de la perspective Integration et les stocker dans le Repository du Studio.

Vous pouvez sélectionner n'importe quelle variable de contexte du Repository à partir de l'éditeur de rapports de la perspective Profiling et l'utiliser pour stocker les résultats du rapport.

Pour plus d'informations concernant les contextes et comment les centraliser dans le référentiel du studio, consultez Utiliser les contextes et les variables.

Exporter les paramètres du datamart de rapports en tant que contextes

Prérequis : Vous devez avoir défini les paramètres du datamart de rapports dans la fenêtre [Preferences] comme expliqué dans Configurer une base de données distante. Vous devez avoir sélectionné la perspective Profiling du Studio.

Afin d'exporter les paramètres de la base de données de rapports en tant que contexte et utiliser les variables de contexte dans l'éditeur de rapports, procédez comme suit :

  1. Dans la barre de menu, cliquez sur Window > Preferences afin d'ouvrir la fenêtre [Preferences].

  2. Commencez à taper Reporting dans le champ de filtre puis sélectionnez Reporting dans la liste afin d'ouvrir la page [Reporting].

  3. Cliquez sur Export as context afin d'ouvrir l'assistant de création de contextes.

  4. Suivez les étapes dans l'assistant afin de définir les variables de contexte et exportez la connexion au datamart ainsi que le chemin vers le dossier de rapports et le logo en tant que contextes.

    Un nom par défaut est donné aux variables de contexte si vous ne changez pas ce dernier dans l'assistant de création de contextes. Les variables de contexte sont centralisées sous le nœud Context de la perspective Integration de votre Studio.

    Pour plus d'informations concernant la centralisation des contextes dans le référentiel du studio, consultez Centraliser les variables de contexte dans le Repository.

    Un message apparaît afin de montrer la progression de l'opération. Les paramètres de connexion sont ensuite en lecture seule.

  5. Vous pouvez cliquer sur Revert Context afin de revenir à l'état initial de la connexion.

  6. Dans l'arborescence DQ Repository, cliquez-droit sur une ou plusieurs analyse(s) et générez un rapport.

    L'éditeur de rapports s'ouvre dans les paramètres de rapport.

    Dans la vue Database Connection Settings en bas de l'éditeur, les paramètres de connexion sont déjà remplis avec les variables de contextes définies et exportés en tant que contexte dans la fenêtre [Preferences]. La table à droite des paramètres de connexion montre les valeurs des contextes de connexion.

    La vue Context group Settings s'ouvre également dans l'espace de modélisation graphique.

    La vue Contexts affiche les variables que vous avez exportées et centralisées dans le Repository du Studio sous le nœud Contexts de la perspective Integration. Si cette vue n'est pas ouverte dans le studio, utilisez le menu Window > Show View > Profiling > Contexts pour l'ouvrir.

    Note

    Un rapport créé dans le Studio avant que vous ayez défini et exporté les variables de contexte garde ses paramètres de base de données originaux. Si vous souhaitez l'utiliser avec un datamart ou des contextes de connexion différents, vous devez ouvrir le rapport et sélectionner la connexion de contexte manuellement dans l'éditeur de rapports. Pour plus d'informations, consultez Sélectionner ou modifier les variables de contexte dans l'éditeur de rapports.

  7. Sauvegardez le rapport et exécutez-le.

    Les résultats du rapport sont écrits dans la connexion de contexte définie dans l'éditeur de rapports.

Sélectionner ou modifier les variables de contexte dans l'éditeur de rapports

Dans la vue Contexts de l'éditeur de rapports de la perspective Profiling, vous pouvez :

  • Cliquer sur le bouton afin de sélectionner des variables de contexte depuis le Repository du Studio. Vous pouvez le faire même si vous n'avez pas exporté les paramètres du datamart en tant que contexte à partir de la fenêtre [Preferences] du Studio.

  • Cliquer sur le bouton [+] au bas de la vue Contexts afin de définir des variables de contexte à partir de zéro.

  • Cliquez sur le bouton [+] dans le coin supérieur droit de la vue pour ouvrir une boîte de dialogue dans laquelle vous pouvez configurer les groupes de contexte pour le rapport.

Pour plus d'informations concernant les contextes et leurs variables, consultez Utiliser les contextes et les variables.

Prérequis : Vous devez avoir sélectionné la perspective Profiling du Studio. Au moins une connexion de contexte a été créée et sauvegardée dans le Repository du Studio.

Pour changer une connexion de contexte pour un rapport à partir de l'éditeur, procédez comme suit :

  1. Double-cliquez sur un rapport dans l'arborescence DQ Repository afin d'ouvrir l'éditeur de rapports.

    Si la vue Contexts n'est pas ouverte dans l'éditeur, utilisez le menu Window > Show View > Profiling > Contexts pour l'ouvrir.

  2. Dans la vue Contexts, cliquez sur le bouton en bas de la vue.

    Une boîte de dialogue s'ouvre afin de lister toutes les variables de contexte créées et centralisées dans le Repository du Studio.

  3. Cochez la case de la connexion de contexte dans laquelle vous souhaitez générer les résultats du rapport sélectionné.

    Vous pouvez sélectionner plus d'une connexion de contexte.

    Si vous ne souhaitez pas obtenir les variables de contexte à partir du Repository du Studio mais que vous voulez les définir à partir de zéro, vous pouvez cliquer sur le bouton [+] en bas de la vue Contexts et définir les valeurs de contexte.

  4. Cliquez sur OK.

    Les variables des connexions de contexte sélectionnées sont listées dans la vue Context et dans la vue Context group Settings.

  5. Saisissez le nom de la (des) variable(s) de contexte de la table Context group Settings dans la vue Database Connection Settings. Saisissez context. suivi du nom de la variable.

  6. Si nécessaire, vous pouvez modifier les variables de contexte dans la vue Contexts en cliquant sur la valeur que vous souhaitez modifier.

    Les valeurs de contexte sont modifiées dans l'éditeur de rapport, mais ces mises à jour ne sont pas propagées au groupe de contexte dans le référentiel. Vous pouvez exécuter uniquement le rapport courant avec les nouvelles valeurs de contexte.

  7. Dans la vue Database Connection Settings, cliquez sur Check afin de vous assurer que votre connexion fonctionne.

  8. Sauvegardez le rapport et exécutez-le.

    Les résultats du rapports sont écrits dans la connexion de contexte définie dans l'éditeur de rapports.