Exporting the report datamart settings as a context - 7.1

Talend Real-time Big Data Platform Studio User Guide

author
Talend Documentation Team
EnrichVersion
7.1
EnrichProdName
Talend Real-Time Big Data Platform
task
Design and Development
EnrichPlatform
Talend Studio

About this task

Prerequisite(s):You have defined the settings of the report datamart in the Preferences window as outlined in Setting up a distant database. You have selected the Profiling perspective in the studio.

To export the settings of the report database as a context and use the context variables in the report editor, do the following:

Procedure

  1. In the menu bar, select Window > Preferences to display the Preferences window.
  2. Start typing Reporting in the filter field and then select Reporting from the list to open the Reporting page.
  3. Click Export as context to open a context creation wizard.
  4. Follow the steps in the wizard to define the context variables and export as a context the datamart connection and the path of the report folder and logo file.
    A by-default name will be given to the context variables if you do not change them in the context creation wizard. The context variables will be centralized under the Contexts node in the DQ Repository tree view.
    For further information about how to centralize contexts in the studio repository, see Centralizing context variables in the Repository.
    A message appears to show the progress of the operation, and then all connection settings become read-only.
  5. If needed, click Revert Context to switch the connection back to its initial state.
  6. In the DQ Repository tree view, right-click, one or several analyses and generate a report.
    The report editor opens on the report settings.
    In the Database Connection Settings view at the bottom of the editor, the connection settings are already filled in with the context variables defined and exported as a context in the Preferences window.
    The Context group Settings view shows the values of the context connection.
    The Contexts view shows the variables you exported and centralized in the studio repository, under the Contexts node in the DQ Repository tree view. If this view is not open in the studio, use the combination Window > Show View > Profiling > Contexts to open it.
    Note: A report created in the studio before you define and export context variables keeps its initial database settings. If you want to use it with a different datamart or context connection, you must open the report and select the context connection manually from the report editor. For further information, see Selecting or updating context variables from the report editor.
  7. Save the report and execute it.
    The report results will be written to the context connection defined in the report editor.