Télécharger et installer les modules dans le Studio Talend

Guide d'installation de Talend Data Management Platform pour Linux

EnrichVersion
6.5
EnrichProdName
Talend Data Management Platform
task
Installation et mise à niveau
EnrichPlatform
Talend Administration Center
Talend Activity Monitoring Console
Talend Data Stewardship
Talend JobServer
Talend SAP RFC Server
Talend Installer
Talend Artifact Repository
Talend Data Preparation
Talend Repository Manager
Talend CommandLine
Studio Talend
Talend Log Server
Talend Identity and Access Management
Talend DQ Portal
Talend Runtime

Avant de commencer

Si vous travaillez derrière un proxy de réseau, assurez-vous d'avoir correctement configuré votre proxy avant de télécharger et d'installer les modules externes dans votre Studio Talend.

Pour accéder aux paramètres du proxy, sélectionnez Window > Preferences depuis le menu pour ouvrir la fenêtre Preferences, puis développez le nœud General et cliquez sur Network Connections.

Ajoutez le site web http://talend-update.talend.com et le port 443 à la liste blanche.

Procédure

  1. Dans l'assistant d'installation des Jar, cliquez sur le bouton Download and Install pour installer un module spécifique, ou cliquez sur le bouton Download and install all modules available pour installer tous les modules disponibles, ou sélectionnez Help > Install Additional Packages depuis le menu pour ouvrir l'assistant Additional Talend Packages. Dans cet assistant, assurez-vous que les cases Optional third-party libraries et Required third-party libraries sont cochées puis cliquez sur Finish. La boîte de dialogue Download external modules s'ouvre.
    Remarque : Cet assistant Additional Talend Packages s'ouvre automatiquement lorsque vous démarrez le Studio Talend si un ou plusieurs paquets supplémentaires, notamment des modules externes, doivent être installés pour l'utilisation d'une fonctionnalité dans le Studio Talend.
  2. Pour télécharger et installer les modules externes fournis sous une licence spécifique, sélectionnez cette licence dans le panneau Licenses, consultez les termes de la licence, sélectionnez l'option I accept the terms of the license agreement et cliquez sur Finish pour démarrer le processus de téléchargement et d'installation.
    Pour télécharger et installer tous les modules externes fournis sous toutes les licences listées, cliquez sur le bouton Accept all pour démarrer le processus de téléchargement et d'installation.
    Lors de l'installation du ou des modules sélectionnés, une boîte de dialogue apparaît pour vous informer du nombre de modules installés avec succès et/ou à propos des modules dont l'installation a échoué, s'il y en a.
    Pour installer manuellement un module externe que vous avez téléchargé localement, procédez comme suit :
    1. Cliquez sur le bouton dans le coin supérieur droit de la vue Modules ou dans l'assistant d'installation de jars afin de parcourir votre système.
      Si la vue Modules n'apparaît pas dans votre espace de modélisation graphique, cliquez sur Window > Show View... > Talend depuis le menu puis sélectionnez Modules dans la liste.
    2. Dans la fenêtre Open de votre système, parcourez votre système jusqu'au module que vous souhaitez installer, double-cliquez sur le fichier .jar ou sélectionnez-le puis cliquez sur Open pour l'installer.
      La boîte de dialogue se ferme et le module sélectionné est installé dans le dossier des bibliothèques de votre Studio Talend.

      Vous pouvez maintenant utiliser le composant ou la métadonnée de connexion nécessitant le module dans vos Jobs.

      Avertissement : En cas de travail collaboratif, une fois le module requis installé dans le Studio Talend d'un utilisateur, les autres utilisateurs peuvent simplement rafraîchir leur vue Modules afin d'ajouter ce module à leur(s) propre(s) Studio Talend(s).