レポートデータマート設定をコンテキストとしてエクスポートする - 7.1

Talend Real-time Big Data Platform Studioユーザーガイド

author
Talend Documentation Team
EnrichVersion
7.1
EnrichProdName
Talend Real-Time Big Data Platform
task
ジョブデザインと開発
EnrichPlatform
Talend Studio

このタスクについて

前提条件: 遠隔データベースのセットアップの手順に従って[Preferences] (環境設定)ウィンドウのレポートデータマートの設定が定義されていること。Studioで Profiling パースペクティブを選択していること。

レポートデータベースの設定をコンテキストとしてエクスポートし、レポートエディターでコンテキスト変数を使用するには、次の手順に従います。

手順

  1. メニューバーで、[Window] (ウィンドウ) > [Preferences] (環境設定)の順に選択し、[Preferences] (環境設定)ウィンドウを開きます。
  2. フィルターフィールドに[Reporting] (レポート)の最初の数文字を入力して、リストから[Reporting] (レポート)を選択して、[Reporting] (レポート)ページを開きます。
  3. [Export as context] (コンテキストとしてエクスポート)をクリックし、コンテキスト作成ウィザードを開きます。
  4. ウィザードの手順に従ってコンテキスト変数を定義し、データマート接続とレポートフォルダーおよびロゴファイルのパスをコンテキストとしてエクスポートします。
    コンテキスト作成ウィザードで名前を変更しない場合、コンテキスト変数にデフォルトの名前が付与されます。コンテキスト変数は[DQ Repository] (DQリポジトリ)ツリービューの[Contexts] (コンテキスト)ノードの下で一元管理されます。
    コンテキストをStudioリポジトリーに一元化する方法の詳細については、リポジトリー内でコンテキスト変数を一元管理するを参照してください。
    オペレーションの進行状況を示すメッセージが表示され、全ての接続設定が読み取り専用になります。
  5. 必要であれば、[Revert Context] (コンテキストから戻す)をクリックして、接続を最初の状態に切り替えることができます。
  6. [DQ Repository] (DQリポジトリー)ツリービューで1つ以上の分析を右クリックし、レポートを生成します。
    レポートエディターでレポート設定が開きます。
    エディターの下にある[Database Connection Settings] (データベース接続設定)ビューで、接続設定は定義されたコンテキスト変数に従って既に入力されており、[Preferences] (環境設定)ウィンドウにコンテキストとしてエクスポートされます。
    [Context group Settings] (コンテキストグループ設定)ビューに、コンテキスト接続の値が表示されます。
    [Contexts] (コンテキスト)ビューには、 [DQ Repository] (DQリポジトリ)ツリービューの[Contexts] (コンテキスト)ノードの下のStudioリポジトリーにエクスポートされて一元化された変数が表示されます。Studioでこのビューが開かない場合、[Window] (ウィンドウ) > [Show View] (ビューの表示) > [Profiling] (プロファイリング) > [Contexts] (コンテキスト)の順に選択して開きます。
    注: コンテキスト変数を定義、エクスポートする前にStudioで作成されたレポートは、元のデータベース設定を保持します。別のデータマートやコンテキスト接続で使用する場合は、レポートエディターでレポートを開いてコンテキスト接続を手動で選択する必要があります。詳細は、レポートエディターからコンテキスト変数を選択または更新するを参照して下さい。
  7. レポートを保存し、実行します。
    レポートエディターで定義されたコンテキスト接続にレポートの結果が書き込まれます。