Bases de données compatibles

Guide d'installation de Talend ESB pour Windows

EnrichVersion
6.5
EnrichProdName
Talend ESB
task
Installation et mise à niveau
EnrichPlatform
Talend Log Server
Talend Runtime
Talend Installer
Talend Data Preparation
Talend Administration Center
Talend Activity Monitoring Console
Talend Data Stewardship
Studio Talend
Talend ESB
Talend CommandLine
Talend Identity and Access Management
Talend Artifact Repository
Les tableaux suivants fournissent des informations sur les bases de données recommandées et supportées que vous pouvez utiliser avec les modules serveur Talend.

Dans la suite de ce document :

  • recommandé : désigne un environnement recommandé par Talend sur la base de l'utilisation Talend et client ;

  • supporté : désigne un environnement supporté pour une utilisation avec les composants ou services listés ;

  • supporté avec limitations : désigne un environnement qui est supporté par Talend sous certaines conditions détaillées dans des notes.

Talend Administration Center

Type de support

Base de données

Note

Recommandé

MySQL 5.7

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

Oracle 12c

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

Supporté

Azure SQL

Le seul pilote supporté est le pilote jTDS-1.3.1.jar patché. Pour plus d'informations, consultez Installer des pilotes de base de données dans votre serveur d'application Web.

H2 1.4

Embarquée, à des fins de test, de développement et de démonstration. Non recommandée pour les environnements de production.

MariaDB 10.1

 

MS SQL Server 2016

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

Seul le pilote JTDS 1.3.1 est supporté.

MS SQL Server 2014

Seul le pilote JTDS 1.3.1 est supporté.

MS SQL Server 2012 (SP2)

Seul le pilote JTDS 1.3.1 est supporté.

MySQL 5.6

Seules les tables InnoDB sont supportées.

Oracle 11g

 

PostgreSQL 9.6

 

PostgreSQL 9.5

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

PostgreSQL 9.4

Une version 9.4 ou supérieure du pilote PostgreSQL JDBC doit être utilisée.

Service Activity Monitoring (SAM)

Type de support

Base de données

Note

Recommandé

MySQL 5.7

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

Oracle 12c

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

Supporté

Azure SQL

 

Derby DB > 10.8

 

IBM DB2 10.1

 

MS SQL Server 2016

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

MS SQL Server 2014

 

MS SQL Server 2012 (SP2)

 

MySQL 5.6

Seules les tables InnoDB sont supportées.

Oracle 11g

 

PostgreSQL 9.6

La version Google Cloud SQL correspondante est supportée.

PostgreSQL 9.5

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

PostgreSQL 9.4

Une version 9.4 ou supérieure du pilote PostgreSQL JDBC doit être utilisée.

ESB Service Registry/Authorization/Talend Identity Management/Event Logging

Type de support

Base de données

Note

Recommandé

MySQL 5.7

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

Oracle 12c

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

Supporté

Azure SQL

 

Derby DB > 10.8

 

MS SQL Server 2016

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

MS SQL Server 2014

 

MS SQL Server 2012 (SP2)

 

MySQL 5.6

Seules les tables InnoDB sont supportées.

Oracle 11g

 

PostgreSQL 9.6

La version Google Cloud SQL correspondante est supportée.

PostgreSQL 9.5

La version Amazon Relation Database Service (Amazon RDS) correspondante est supportée.

PostgreSQL 9.4

Une version 9.4 ou supérieure du pilote PostgreSQL JDBC doit être utilisée.

Talend Data Preparation

Type de support

Base de données

Recommandé (embarqué dans le produit)

MongoDB 3.4

Talend Data Stewardship

Type de support

Base de données

Recommandé (embarqué dans le produit)

MongoDB 3.4