Talend 组件支持的系统、数据库和业务应用程序 - 7.1

Talend Open Studio for ESB 安装与升级指南 (Linux)

EnrichVersion
7.1
EnrichProdName
Talend Open Studio for ESB
task
数据治理
EnrichPlatform
Talend ESB
Talend Runtime
Talend Studio
对这些系统、数据库和业务应用程序的访问因您使用的 Studio 而异。
系统/数据库 版本 操作系统 说明
Access 2003

2007

Windows 使用 Java 8 时,仅支持常规排序模式。
Amazon Aurora Amazon Aurora MySQL v5 版 (MySQL 5.6/5.7)    
Amazon RDS for Microsoft SQL Server N/A    
Amazon Redshift Amazon Redshift 的初始版本 N/A  
AS/400 V6R1 至 V7R2

(不推荐使用版本:V5R2 到 V5R4/V5R3,再到 V6R1)

N/A  
Bonita 6.5.2

7.2.4

(不推荐使用版本:5.2.3/5.3.1/5.6.1/5.10.1)

N/A  
Cassandra 3.0/3.1/3.2/3.3/3.4

(不推荐使用版本:1.1.2/1.2.2/2.0.0)

Windows + Linux  
CouchBase 5.x

6.0

(不推荐使用版本:2.0/4.x)

Windows  
CouchDB 1.0.2 Windows  
数据库通用 ODBC Windows  
DynamoDB 无指定的版本 N/A  
Elasticsearch 2.3.x

5.6.x

(不推荐使用版本:1.7.x)

N/A  
EXASolution 6.0 及更早的版本 Windows  
Excel N/A N/A  
eXist-db 1.4.0 N/A  
FireBird 2.1 Windows + Linux  
FTP N/A    
Greenplum 4.3.x

5.x

(不推荐使用版本:4.2.1.0)

Windows (仅客户端) + Linux  
Hbase N/A    
HDFS N/A    
Hive N/A    
HSQLDb 1.8.0 N/A  
IBM DB2 和 IBM DB2 Z/OS 10.5

11.1

(不推荐使用版本:10.1)

Windows + Linux  
Impala N/A    
Informix 11.50 Windows + Linux  
Ingres 10.2

11

(不推荐使用版本:9.2)

Windows + Linux  
Interbase (不推荐使用版本:7 和更高版本)    
JavaDB 6 Windows + Linux  
JDBC N/A    
JSON N/A    
Kafka 0.8.2.0

0.9.0.1

0.10.0.1

1.1.0

Windows + Linux Kerberos kinit 选项和 Kerberos keytab 选项均受 Talend Studio 支持。有关受 Kafka 组件支持的安全选项的信息,请参阅Talend Help Center
LDAP 无版本限制 Windows + Linux  
MapRDB N/A    
MarkLogic V9 N/A  
MaxDB 7.6 N/A  
Microsoft AX Dynamics AX 4.0

Dynamics AX 2012

N/A  
Microsoft CRM 2011

2015

2016

N/A  
Microsoft CRM在线 2011

2016

N/A  
Microsoft SQL Server 2014

2016

Azure SQL Database

(不推荐使用版本:2000/2003/2005/2008/2012)

Windows + Linux 不支持 MS SQL Server 2014/2016 中推出的新功能。
MongoDB 3.4.x

3.6.x

4.0.x

(不推荐使用版本:2.5.x/2.6.x/3.0.x/3.2.x)

Windows + Linux  
MySQL MySQL 5.x

MySQL 8.x

MariaDB

Google Cloud SQL

(不推荐使用版本:MySQL 4)

Windows + Linux  
MOM N/A    
Neo4j 1.x.x

2.x.x/2.2.x/2.3

3.2.x

Linux  
Netezza 7.0.x

7.1.x

7.2.x

Windows + Linux  
NetSuite 2018

(不推荐使用版本:2014/2016)

Windows + Linux  
OleDb 2000

2003

2005

2007

2010

N/A  
Oracle Oracle 12c Release 1

Oracle 18c

(不推荐使用版本:Oracle 8i/Oracle 9i/Oracle 10g/Oracle 11g)

Windows + Linux  
ParAccel 3.1

3.5

N/A  
PostgreSQL 9/9.x 以前

9.x

10.x

Google Cloud SQL

Windows + Linux  
PostgresPlus 9/9.x 以前

9.x

Windows + Linux  
Red Hat BRMS 6.1 Windows + Linux  
REST 服务 N/A Windows + Linux  
Sage X3 N/A    
Salesforce V44 及更早的版本 Windows + Linux  
SAP 4.6    
SAP Business Suite (ERP) Netweaver:从 7.3 到 7.5

ERP6.0,从 EhP6 到 EhP8

Windows  
SAP Business Warehouse (BW) Netweaver:从 7.31 到 7.5 Windows  
SAP HANA 1.0

2.0

Windows 通过 SAP JDBC 驱动程序来支持
SAS 9.1

9.2

Windows + Linux  
SOAP 服务 N/A    
SQLite 3.6.7 Windows + Linux  
Sqoop N/A    
SugarCRM 5.2 Windows + Linux  
Sybase 12.5

12.7

15.2

15.5

15.7

16.0

Windows + Linux  
SybaseIQ 12.5

12.7

15.2

16.0

Windows + Linux  
Teradata 12

13

14

15

16

Windows + Linux  
VectorWise 2 Windows + Linux  
Vertica 9.0.x

(不推荐使用版本:3/3.5/4/4.1/5.0/5.1/6.0/6.1.x/7.0.x/7.1.x)

Windows + Linux  
VtigerCRM Vtiger 5.0

Vtiger 5.1

N/A