Requiring a JDK installation to build jobs starting from version 6.0

author
Shicong Hong
EnrichVersion
6.5
EnrichProdName
Talend Big Data Platform
Talend Big Data
Talend Data Integration
Talend Data Services Platform
Talend ESB
Talend Open Studio for Data Integration
Talend Data Fabric
Talend Open Studio for ESB
Talend Open Studio for MDM
Talend Real-Time Big Data Platform
Talend MDM Platform
Talend Data Management Platform
Talend Open Studio for Big Data
task
Installation and Upgrade
EnrichPlatform
Talend Studio

Requiring a JDK installation to build jobs starting from version 6.0

This article uses JDK8 to demonstrate how to configure the JDK path in Talend Studio.

Starting from version 6.0, Talend Studio requires a JDK installation on your machine instead of JRE only to build jobs. You must configure the JDK path from the Installed JREs window in Talend Studio before building jobs. Otherwise, the target archive file will not be created.

For more information on how to select the correct JDK version according to your Talend product version, see the Talend installation documentation on Talend Help Center.

Configure the JDK path in Talend Studio

A Wrong Java setup dialog pops up whenever your Talend Studio starts up.

Procedure

  1. Click Windows > Preferences, expand the Java node, and then click Installed JREs.
  2. Click the Add button to install a new JRE or click the Edit button to edit an existing JRE.
  3. Browse to the location of your JDK8 is installed and selected it, in this example C:\Program Files\Java\jdk1.8.0_144.
  4. Click OK to validate your change and close the window.
    Warning: If you have several Java installed, make sure to remove the JREs in the Installed JREs window, in order to avoid the JRE to take precedence over the JDK.