TPS-3279 - 7.2

author
Talend Documentation Team
EnrichVersion
7.2
EnrichProdName
Talend ESB
EnrichPlatform
Talend ESB

TPS-3279

Info Value
Patch Name Patch_20190801_TPS-3279_v1_7.2.1
Release Date 2019-07-24
Target Version 20190620_1446-V7.2.1
Product affected Talend ESB Runtime

Introduction

This patch is independent. It solves the Encryption of user passwords does not work as expected.

NOTE: To download this patch, liaise with your Support contact at Talend.

Fixed issues

This patch contains the following fixes:

  • TESB-26507: Encryption of user passwords does not work as expected

Prerequisites

Consider the following requirements for your system:

  • Talend ESB Runtime 7.2.1 must be installed.

Installation

Installing the patch manually

Apply the patch on Talend Runtime 7.2.1

  1. Delete the 'org.apache.karaf.jaas.modules-4.2.4.jar' from the folder 'Runtime_Home/system/org/apache/karaf/jaas/org.apache.karaf.jaas.modules/4.2.4/'
  2. Copy&Replace the patch files from the system/ folder, into the 'Runtime_Home/system/'
  3. On Linux:
  4. 'cp -rf ./system Runtime_Home/system'
  5. On Windows:
  6. 'xcopy system\*.* Runtime_home\system /s'
  7. (Press "y" when prompting if overwrite the features xml file)
  8. Update/Refresh the feature xml files and the installed features
  9. karaf@trun()> feature:repo-refresh
  10. karaf@trun()> feature:refresh
  11. Restart the Runtime Container, and check if the patched org.apache.karaf.jaas.modules bundle is started properly
  12. (check with 'la' command)
  13. karaf@trun()> la |grep "Apache Karaf :: JAAS :: Modules"
  14. 112 | Active | 30 | 4.2.4.tesb1 | Apache Karaf :: JAAS :: Modules

NOTE: This patch fixed the regression behavior "have access to the Runtime without being prompted to enter password in case of encryption enabled". Before apply the patch, the assumption is you've configured these properties in the Runtime/etc/org.apache.karaf.jaas.cfg - encryption.enabled = true - encryption.name = basic (or jasypt)