Compatible Apache software and JMS Brokers for Talend ESB - 6.2

Talend ESB Installation Guide for Linux

EnrichVersion
6.2
EnrichProdName
Talend ESB
task
Installation and Upgrade
EnrichPlatform
Talend Activity Monitoring Console
Talend Administration Center
Talend Artifact Repository
Talend CommandLine
Talend ESB
Talend Identity Management
Talend Installer
Talend JobServer
Talend Log Server
Talend Project Audit
Talend Runtime
Talend Studio

The information contained in the following table is applicable for the 6.2.2 version of your Talend product at the time of its release. For updated information on the latest supported software or databases, see this page.

Some of the ESB tools use Apache software components. Talend ESB contains the following Apache Project versions:

Table 9. Supported Apache software

Software

Version

Notes

More information

Apache Karaf

4.0.5

Service release upgrade.

Release notes: https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140&version=12334629

Apache CXF

3.1.5

Service release upgrade.

Release notes and Migration Guide: http://cxf.apache.org/cxf-315-release-notes.html

Apache Camel

2.16.3

Minor release upgrade.

Release notes: http://camel.apache.org/camel-2163-release.html

Apache ActiveMQ

5.13.3

Minor release upgrade.

Release notes: http://activemq.apache.org/activemq-5133-release.html

Apache Syncope

1.2.7

Minor release upgrade.

Release notes: https://cwiki.apache.org/confluence/display/SYNCOPE/Intermezzo#Intermezzo-1.2.7(January15th,2016)


Talend ESB supports the following JMS Brokers.

Note that ESB Java Consumer & Provider using SOAP/JMS-based messaging are supported for the following (JMS) Message-Brokers.

Table 10. Supported Messaging Brokers for SOAP/JMS

Software

Version

Apache ActiveMQ

5.13.3

IBM WebSphere MQ

7.1 and 7.5