Editer le Manifest d'une Route

Talend ESB Studio Guide utilisateur

EnrichVersion
6.1
EnrichProdName
Talend ESB
task
Création et développement
EnrichPlatform
Studio Talend

Le Route designer vous permet de gérer les dépendances OSGI d'une Route. Pour ce faire :

  1. Double-cliquez sur la Route pour l'ouvrir et cliquez sur l'onglet Dependencies pour afficher l'éditeur de Manifest.

  2. Dans la zone Import Packages, les packages système sont affichés en italique. Cliquez sur Add pour ajouter un nouveau package.

  3. Dans l'assistant [Add Import-Package], saisissez les propriétés comme expliqué dans le tableau ci-dessous puis cliquez sur OK. Les packages ajoutés manuellement s'affichent en noir. Vous pouvez également modifier les propriétés de ceux-ci en cliquant sur le bouton Edit après avoir ajouté le package. Vous pouvez aussi le supprimer en cliquant sur le bouton Remove.

    Champ

    Description

    Name

    Saisissez le nom du Import-Package.

    Properties / Optional

    Cochez cette case pour résoudre le package uniquement s'il est présent.

    Version to match/MinVersion

    Spécifiez la version minimale du package correspondant à l'Export-Package. Si cet attribut n'est pas spécifié, la valeur par défaut est 0.0.0. Vous pouvez choisir entre Inclusive et Exclusive pour inclure ou exclure, respectivement, la version spécifiée. Cela est visible dans le nom du package. Les parenthèses "()" indiquent l'exclusion de la version spécifiée. Les crochets "[]" indiquent l'inclusion de la version spécifiée. (xxx) indique une version unique.

    Version to match/MaxVersion Spécifiez la version maximale du package correspondant à l'Export-Package. Si cet attribut n'est pas spécifié, la valeur par défaut est ∞. Vous pouvez choisir entre Inclusive et Exclusive pour inclure ou exclure, respectivement, la version spécifiée. Cela est visible dans le nom du package. Les parenthèses "()" indiquent l'exclusion de la version spécifiée. Les crochets "[]" indiquent l'inclusion de la version spécifiée. (xxx) indique une version unique.
  4. Dans la zone Export Packages, les packages système sont affichés en italique. Cliquez sur Add pour ajouter un nouveau package.

  5. Dans l'assistant [Add Export-Package], saisissez les propriétés comme expliqué dans le tableau ci-dessous puis cliquez sur OK. Les packages ajoutés manuellement s'affichent en noir. Vous pouvez également modifier les propriétés de ceux-ci en cliquant sur le bouton Edit après avoir ajouté le package. Vous pouvez aussi le supprimer en cliquant sur le bouton Remove.

    Champ

    Description

    Name

    Saisissez le nom de l'Export-Package.

    Version exported/Version

    Spécifiez la version du package. Le format major.mid.min.qualifiername est supporté. Vous pouvez choisir d'utiliser qualifiername ou non. Si vous saisissez une version contenant moins de trois chiffres, le format major.mid.min est utilisé. Par exemple, si vous saisissez 1, la version affichée sera 1.0.0.

  6. Le chemin de recherche dans le bundle est affiché dans la zone Bundle Classpath. Cliquez sur le bouton Select All ou Diselect All afin de tout inclure ou exclure du bundle OSGI.

  7. Dans la zone Require Bundles, les bundles système sont affichés en italique. Cliquez sur Add pour ajouter un nouveau bundle.

  8. Dans l'assistant [Add Require-Bundle], saisissez les propriétés comme expliqué dans le tableau ci-dessous puis cliquez sur OK. Les bundles ajoutés manuellement s'affichent en noir. Vous pouvez également modifier les propriétés de ceux-ci en cliquant sur le bouton Edit après avoir ajouté le bundle. Vous pouvez aussi le supprimer en cliquant sur le bouton Remove

    Champ

    Description

    Name

    Saisissez le nom du Require-Bundle.

    Properties / Optional

    Cochez cette case pour résoudre le bundle uniquement s'il est présent.

    Version to match/MinVersion

    Spécifiez la version minimum du bundle. Si cet attribut n'est pas spécifié, la valeur par défaut est 0.0.0. Vous pouvez choisir entre Inclusive et Exclusive pour inclure ou exclure, respectivement, la version spécifiée. Cela est visible dans le nom du package. Les parenthèses "()" indiquent l'exclusion de la version spécifiée. Les crochets "[]" indiquent l'inclusion de la version spécifiée. (xxx) indique une version unique.

    Version to match/MaxVersion Spécifiez la version maximum du bundle. Si cet attribut n'est pas spécifié, la valeur par défaut est ∞. Vous pouvez choisir entre Inclusive et Exclusive pour inclure ou exclure, respectivement, la version spécifiée. Cela est visible dans le nom du package. Les parenthèses "()" indiquent l'exclusion de la version spécifiée. Les crochets "[]" indiquent l'inclusion de la version spécifiée. (xxx) indique une version unique.

Dans l'éditeur de Manifest, vous pouvez également :

  • filtrer les packages, bundles, ou les classpaths en saisissant des caractères à rechercher dans le champ Search et supprimer la recherche en cliquant sur le bouton ,

  • cocher la case Hide Built-In Items afin de masquer les éléments système,

  • cliquer sur le bouton pour rafraîchir toutes les dépendances selon le dernier contenu de la Route,

  • cliquer sur le bouton Up ou Down pour déplacer vers le haut ou vers le bas dans la liste, un Import-Package ou un Require-Bundle ajouté manuellement.