Compatible Java Runtime Environments - 7.3

Talend Data Catalog Installation and Upgrade Guide for Windows

author
Talend Documentation Team
EnrichVersion
7.3
EnrichProdName
Talend Big Data Platform
Talend Data Fabric
Talend Data Management Platform
Talend Data Services Platform
Talend MDM Platform
Talend Real-Time Big Data Platform
task
Installation and Upgrade
EnrichPlatform
Talend Data Catalog
In order to use Talend Data Catalog, Java must be installed on your machine. The following table provides information on the supported Java Runtime Environments.

In the following documentation:

  • recommended: designates an environment recommended by Talend based on our experiences and customer usage.
  • supported: designates a supported environment for use with the listed component or service.
  • supported with limitations: designates an environment that is supported by Talend but with certain conditions explained in notes.
Support type JRE version Note
Recommended OpenJDK 11 - 64 bit You do not need to set up OpenJDK 11 as it is embedded in Talend Data Catalog.
Note: Talend does not offer support for the embedded JRE.
Note: Java bridges are compiled to be compatible with JRE 8.
Other Java Runtime Environments such as IBM Java require manual installation/setup and are therefore not supported by this version.