How to validate the version of a Talend function module in SAP

author
Thomas Steinborn
EnrichVersion
6.4
6.3
6.2
6.1
6.0
EnrichProdName
Talend Real-Time Big Data Platform
Talend Data Services Platform
Talend Data Management Platform
Talend Big Data
Talend MDM Platform
Talend ESB
Talend Data Fabric
Talend Data Integration
Talend Big Data Platform
task
Data Governance > Third-party systems > Business applications > SAP components
Design and Development > Third-party systems > Business applications > SAP components
Data Quality and Preparation > Third-party systems > Business applications > SAP components
EnrichPlatform
Talend Studio

How to validate the version of a Talend function module in SAP

In this article, you will learn how to validate a Talend Function module within SAP. You usually need to know a Talend Function module version when you want to verify whether a specific patch has been installed on the SAP server or if you want to check that this version is compatible with your other Talend tools.
Environment

This article is valid for all Talend products on subscription from v5.6 upwards.

Procedure

This procedure does entirely take place in your SAP System.

  1. Connect to your SAP system.

  2. Call the transaction code: SE37 Function Builder.

  3. In the Function Builder , type in the name of the Function Module you want to check the version of.

    Talend uses the following modules:

    • Z_TALEND_READ_TABLE
    • Z_TALEND_READ_INFOPROV
    • Z_TALEND_UPSERT_ODSO
  4. Click Display.

The version of the selected Function Module displays in the comment area, so does the patch which have been installed also. In this example, the Function Module installed is v1.0.

What to do next

Once you have collected the version of your Function Module(s), check the compliance matrix detailed in the article: Which version of SAP Function Modules ships with which Talend version? .