Java - 6.3

Talend Data Services Platform Guide d'installation pour Mac

EnrichVersion
6.3
EnrichProdName
Talend Data Services Platform
task
Installation et mise à niveau
EnrichPlatform
Studio Talend

Afin d'utiliser votre produit Talend, Java doit être installé sur votre machine. Ces pages listent :

Environnements Java compatibles

Note

Dans la suite de ce document :

  • recommandé : désigne un environnement recommandé par Talend sur la base de l'utilisation Talend et client ;

  • supporté : désigne un environnement supporté pour une utilisation avec les composants ou services listés ;

  • supporté avec limitations : désigne un environnement qui est supporté par Talend sous certaines conditions détaillées dans des notes.

Les tableaux suivants présentent une liste exhaustive des environnements Java compatibles.

Dans ce tableau :

  • (R) signifie que cette combinaison est recommandée ;

  • signifie que cette combinaison est supportée ;

  • signifie que cette combinaison n'est pas supportée.

Notez que seules les versions 64 bits des environnements Java compatibles sont supportés.

Le niveau de conformité du compilateur (Compiler Compliance Level) correspond à la version de Java utilisée pour la génération de code des Jobs. Cette option peut être changée dans les préférences du Studio. Pour plus d'informations, consultez le Guide utilisateur du Studio Talend.

Tableau 6. Environnements Java pour le Studio

Type de support

Version JRE

Niveau de conformité du compilateur JDK du Studio (Compiler Compliance Level)

Recommandé

Oracle 8

1.7 (par défaut)

Supporté

Oracle 8

1.8


Suivant votre licence, les serveurs d'exécutions disponibles peuvent être différents.

Tableau 7. Environnements Java pour les serveurs

Version JRE

JobServer

MDM Runtime

ESB/Talend Runtime

ESB/Microservices

Distributions Big Data

Applications serveur Talend1

Commentaires/Limitations

Oracle 7 (s'exécutant avec Oracle 8)

Compatibles avec Java 1.7 uniquement

Uniquement compatible avec le niveau de conformité du compilateur JDK du Studio (Compiler Compliance Level) défini sur 1.7.

Oracle 8

(R)

(R)

(R)

(R)

Compatibles avec Java 1.8

(R)

Compatible avec le niveau de conformité du compilateur JDK du Studio (Compiler Compliance Level) défini sur 1.7 (par défaut et recommandé) ou 1.8.

IBM 8

Uniquement pour AIX et SUSE SLES.


1 : Les applications serveur Talend comprennent Artifact Repository, CommandLine, Talend Activity Monitoring Console, Talend Administration Center, Talend Data Preparation, Talend Data Quality Portal, Talend Data Stewardship, Talend Log Server, Talend Repository Manager.

Par exemple, la combinaison recommandée est la suivante :

  • Oracle 8 installé sur la machine exécutant le Studio ;

  • 1.7 défini dans les préférences du niveau de conformité du compilateur du Studio (Compiler Compliance Level) ;

  • Oracle 8 installé sur la (les) machine(s) exécutant le(s) serveur(s) d'exécution et l' (les) application(s) serveur Talend ;

  • des Distributions Big Data compatible avec Java 1.8 utilisées.

Pour plus d'informations sur les spécificités Java (compatibilité des versions, des systèmes d'exploitation), consultez Talend Help Center et Talend Community.

Définir JAVA_HOME

Afin que votre produit Talend puisse utiliser l'environnement Java installé sur votre machine, vous devez définir la variable d'environnement JAVA_HOME.

Pour ce faire, procédez comme suit :

  1. Trouvez le dossier dans lequel Java est installé, généralement /Library/Java/Home.

  2. Ouvrez un terminal.

  3. A l'aide de la commande export, définissez les variables JAVA_HOME et Path.

    Pour exemple :

    export JAVA_HOME=/usr/lib/jvm/jre1.8.0_65
    export PATH=$JAVA_HOME/bin:$PATH
  4. Ajoutez ces lignes à la fin de profils globaux dans le fichier /etc/profile ou dans les profils utilisateur dans le fichier ~/.profile.

    Après avoir changé un de ces fichiers, vous devez vos déconnecter et vous reconnecter.