How to launch the Studio for the first time

Talend Data Fabric Getting Started Guide

EnrichVersion
6.1
EnrichProdName
Talend Data Fabric
task
Data Governance
Design and Development
Data Quality and Preparation
EnrichPlatform
Talend Studio

To open Talend Studio for the first time, complete the following:

  1. Uncompress the Talend Studio zip file and, in the folder, double-click the executable file corresponding to your operating system.

    Note

    The Studio zip archive contains binaries for several platforms including Mac OS X and Linux/Unix.

  2. In the [User License Agreement] dialog box that opens, read and accept the terms of the end user license agreement to proceed.

  3. In the dialog box that opens prompting you to load your product license, select an option to specify your license, before clicking Next to load it into your Studio.

    • If you have already set your license and project in Talend Administration Center, select My product license is on a remote host, fill in the credentials and the URL of your Talend Administration Center Web application, and click Fetch to retrieve the license. In this way, you do not have to set up a remote repository as the settings of the project you created in the Web application are automatically retrieved. Then, click Next to go to the login window to:

    • If your license file is stored locally on your computer, select My product license is on the local file system, click Browse to browse to your license file, and then double-click it.

      Alternatively you can quickly load your license by dragging and dropping your locally stored license file directly onto the right panel of this dialog box without having to select an option.

    This procedure assumes the your license file is stored locally, so select the second option and browse to and open your license file, and then click Next to load your license and go to the next step to set up your project.

    Note

    The license comes with your Talend Studio product subscription and determines the edition of Talend Studio you can have access to.

  4. In the Talend Studio login window, select an option to define your project that will hold all Jobs and Business models designed in the Studio.

    Note

    This login window appears only when the Studio is started for the first time with a license loaded from your local file system. When you launch the Studio again using a locally loaded license, the normal login window opens, which provides one more option, a connection list box, for subscription-based users to select a repository connection when launching the Studio.

    If you plan to use the same repository connection and / or project at your next Studio launch, you can skip the login window to speed up Studio launch by clearing the Always ask me at startup check box. Then, if you want to see the login window again, go to the menu Window > Preferences to open the [Preferences] window, select Talend, and select the Always show project dialog at startup check box.

    • Select Create a new project, specify a project name and click Finish to create a new local project. For more information, see How to create a project.

    • Select Import a demo project and click Finish to import a demo project that includes numerous samples of ready-to-use Jobs. This Demo project can help you understand the functionalities of different Talend components. For more information, see How to import a demo project.

    • Select Import an existing project and click Finish to import an existing projects stored locally. For more information, see your Talend Studio User Guide.

    • If you want to modify the default repository connection or create a new one, click Manage Connections to set up your connection before setting up a project. For further information about connecting to a repository, see How to access a Repository.

    As the purpose of this procedure is to create a new localproject, select Create a new project, fill in a project name in the text field, and click Finish.

  5. Depending on the license you are using, you will see either of the following:

    • A Quick Tour to Talend Studio. Click Next to go the next slide of the presentation, or click Close to end the presentation and display the main window of your Talend Studio.

      This presentation automatically starts at the Studio initial launch. To open it manually later, go to Help > Studio Quick Tour from the Studio menu bar.

    • The [Welcome] window, which provides direct links to Demo projects, user documentation, tutorials, Talend Community, Talend on-demand training and Talend latest news. Click Start now! to open Talend Studio main window, which displays a page that provides useful tips for beginners on how to get started with the Studio. Clicking an underlined link brings you to the corresponding tab view or opens the corresponding dialog box.

    When the [Additional Talend Packages] wizard opens, install additional packages such as language packs if needed. For more information, see the section about installing additional packages in the Talend Installation Guide.

  6. You can skip this installation step and close the wizard by clicking Cancel.

    This wizard appears each time you launch the studio if any additional package is available for installation unless you select the Do not show this again check box. You can also display this wizard by selecting Help > Install Additional Packages from the menu bar.

Note

When opening the Studio for the first time, the perspective displayed will depend on the license used, so it might not be the Integration perspective at first. For example, if you are using a Master Data Management license, the MDM perspective will open first. To display the Welcome page, you will have to switch to the Integration perspective.