EC2 server with existing AMI not supported in Talend Administration Center v6.0.1 v6.1.1

author
Talend Documentation Team
EnrichVersion
6.1
EnrichProdName
Talend Real-Time Big Data Platform
Talend Data Fabric
Talend MDM Platform
Talend Data Services Platform
Talend Data Management Platform
Talend Big Data Platform
task
Installation and Upgrade
Administration and Monitoring > Managing servers
EnrichPlatform
Talend Administration Center
Talend JobServer

EC2 server with existing AMI not supported in Talend Administration Center v6.0.1 v6.1.1

EC2 server with existing AMI not supported in Talend Administration Center v6.0.1 v6.1.1
Environment

This articles applies to Talend Administration Center v6.1.1 and v6.0.1.

Symptoms/Description

In Talend Administration Center v6.0.1 and v6.1.1, users cannot create an EC2 server based on the default AMI provided.

Reason: The EC2 instance created with the default AMI is using JDK 1.6.x, whereas the JobServer in Talend 6.0.1 and 6.1.1 is built based on JDK 1.7.x.

Resolution1. Create your instance in AWS:
  • Install JDK 1.7/1.8
  • Install JobServer
  • Enable JobServer as a service to start it automatically
  • Create an Image based on the EC2 instance that you want to use (Image will have an ID)

2. In Talend Administration Center:

  • On the Servers page, create the EC2 jobserver, unselect the Select AMI check box to use an existing AMI (the one created previously).
  • On the Job Conductor page, link the task to the JobServer and run it.
  • The run or deploy action will create the instance. Provided that the JobServer is well installed as a service, the startup of the instance will start the JobServer as well and your Job will be deployed/executed.
Related Jira Issues

TDI-33062

TDI-35427