Compatible Java Environments

Talend Open Studio for ESB Installation and Upgrade Guide for Windows

EnrichVersion
6.5
EnrichProdName
Talend Open Studio for ESB
task
Installation and Upgrade
EnrichPlatform
Talend Runtime
Talend Studio
Talend ESB

The following tables provide information on the recommended Java Environment you should download and install to use your Talend product.

The Compiler Compliance Level corresponds to the Java version used for the Job code generation. This option can be changed in the Studio preferences. For more information, see the Talend Studio User Guide.

Note: All Talend products and associated third-party applications, such as the Hadoop cluster, should use the same Java version for compliance. Before you install or upgrade any associated third-party application, Talend recommends that you check which Java version they support.

In the following documentation:

  • recommended: designates an environment recommended by Talend based on our experiences and customer usage;

  • supported: designates a supported environment for use with the listed component or service;

  • supported with limitations: designates an environment that is supported by Talend but with certain conditions explained in notes.

Studio Java environments

Support type

JRE Version

Studio JDK Compiler Compliance Level

Note

Recommended

Oracle 8

1.8 (default)

 

Supported

Oracle 8

1.7 (with restrictions)

Only supported for Big Data distributions requiring JDK 1.7. Routes are not supported by Talend Studio JDK Compiler Compliance Level 1.7.

Server Java environments

The server modules include:

  • Talend ESB Servers
  • Talend Runtime

JRE Version

Talend JobServer

Talend MDM Server

Talend ESB/Talend Runtime

Talend ESB/Microservices

Big Data Distributions

Talend Server Application

Comment/Limitation

Oracle 7

Compatible with Java 1.7 only

Compatible with Talend Studio JDK Compiler Compliance Level 1.7 only

Oracle 8

(R)

(R)

(R)

(R)

Compatible with Java 1.8

(R)

Compatible with Talend Studio JDK Compiler Compliance Level 1.7 (default/recommended) or 1.8

IBM 8

Only for AIX and SUSE SLES (deprecated)