互換性があるデータベース - 8.0

Linux版Talendインストールガイド

Version
8.0
Language
日本語 (日本)
EnrichDitaval
Linux
Product
Talend Big Data
Talend Big Data Platform
Talend Data Fabric
Talend Data Integration
Talend Data Management Platform
Talend Data Services Platform
Talend ESB
Talend MDM Platform
Talend Real-Time Big Data Platform
Module
Talend Activity Monitoring Console
Talend Administration Center
Talend Artifact Repository
Talend CommandLine
Talend Data Preparation
Talend Data Stewardship
Talend ESB
Talend Identity and Access Management
Talend Installer
Talend JobServer
Talend Log Server
Talend MDM Server
Talend MDM Web UI
Talend Runtime
Talend SAP RFC Server
Talend Studio
Content
インストールとアップグレード
次のテーブルは、Talendサーバーモジュールと共に使用可能な推奨およびサポートされるデータベースに関する情報をまとめたものです。

次のようなサポートタイプがあります。

  • 推奨: 経験とカスタマー事例に基づいてTalendにより推奨される環境を示します。
  • サポート: リストされているコンポーネントまたはサービスの使用においてサポートされる環境を示します。
  • 制限付きサポート: メモで説明されている特定の条件付きでTalendによってサポートされる環境を示します。

Talend Administration Center

Talend Administration Centerと互換性があるデータベース
データベース バージョン サポートされているドライバー サポートタイプ
MySQL4,5 8.0 mysql-connector-java-8.x.jar 推奨
5.7 サポート
Oracle 19c ojdbc10.jar

ojdbc8.jar

推奨
18c サポート
Azure SQL -

mssql-jdbc-9.4.0.jre11.jar

mssql-jdbc-9.4.0.jre8.jar

サポート
H2 1

2.16

h2-2.1.210.jar

本番環境ではサポートされていません
MariaDB 2 10.5 mariadb-java-client-2.7.4.jar サポート
MS SQL Server 3 2019

mssql-jdbc-10.2.0.jre11.jar

mssql-jdbc-10.2.0.jre8.jar

mssql-jdbc-9.4.0.jre11.jar

mssql-jdbc-9.4.0.jre8.jar

サポート
2017 サポート
2016 サポート
2014 サポート
PostgreSQL 13 postgresql-42.2.10.jar サポート
12 サポート
11 サポート
10 サポート
9.6 サポート
Aurora 2.07.2 mysql-connector-java-8.0.26.jar サポート
注: 上記のデータベースは、ホスティングモード、Google Cloud Platform、Amazon RDSが含まれているかどうかに関わらずすべてサポートされています。

1 開発、テスト、デモ用に組み込まれています。前のバージョンから移行する場合は、H2はサポートされていません。前のバージョンから移行するには、まずソースバージョンでH2からMySQLまたは他のサポートされるデータベースに移行した後に、Talend Administration Centerのターゲットバージョンへのアップグレードをトリガーする必要があります。

2 MariaDB 10.1を使ってデータベーススキーマを作成する場合は、UTF8エンコーディングを使う必要があります。例: CREATE DATABASE <YOUR_DATABASE_NAME> DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_general_ci;

3 Talendは、Microsoft SQL Server 2016以降のAlways Encrypted機能をサポートしています。MSSQLクラスターはTalend Administration Centerでサポートされています。

4 MySQL InnoDBクラスターはTalend Administration Centerによってサポートされています。InnoDBクラスターを使う場合は、JDBCUrl:jdbc:mysql://192.168.1.32:6446/TAC?useSSL=true&connectTimeout=15000&socketTimeout=15000&autoReconnect=trueのように、クラスターシステム環境であるJDBC URLを変更しなければならない場合があります。192.168.1.32はmysqlrouterホストのIPアドレスであり、6446はmysqlルーターのRWポートです。

My MySQL Route Classicプロトコル: 読み書き接続: localhost:6446読み取り専用接続: localhost:6447

5 Talend Administration Centerは、RedHatクラスタリングによるフェイルオーバー設定のMySQLセットアップをサポートしています。詳細は、https://access.redhat.com/documentation/ja-jp/red_hat_enterprise_linux/7/html/high_availability_add-on_administration/indexをご覧ください。なお、4に示すように、JDBC接続URLにパラメーターをいくつか追加しなければならない場合があります。

6 次の手順に従い、お持ちのH2データベースを2.1バージョンにアップデートしてください: https://help.talend.com/r/ja-JP/8.0/migration-upgrade-guide-big-data/upgrading-administration-database

対象製品:

Data Fabric

MDM Platform

Talend MDM Server

Talend MDM Serverと互換性があるデータベース
データベース バージョン サポートされているドライバー サポートタイプ
MySQL 1、5 8.0 mysql-connector-java-8.x.jar 推奨
5.7 サポート
Oracle 19c ojdbc10.jar

ojdbc8.jar

推奨
18c サポート
AzureSQL - jtds-1.3.1_patched.jar サポート
H2 2

2.16

h2-2.1.210.jar

本番環境ではサポートされていません
IBM DB2 10.5   サポート
MS SQL Server 2019 mssql-jdbc-9.4.0.jre11.jar

mssql-jdbc-10.2.1.jre11.jar 7

サポート
2017 5 mssql-jdbc-9.2.1.jre8.jar

mssql-jdbc-9.2.1.jre11.jar

サポート
2016 サポート
2014 サポート
PostgreSQL 13 postgresql-42.2.2.jre7.jar サポート
12 サポート
11 サポート
10 サポート
9.6 サポート

1 Google Cloud SQLはサポートされています。

2 開発、テスト、デモ用に組み込まれています。

3 MariaDB 10.1を使ってデータベーススキーマを作成する場合は、UTF8エンコーディングを使う必要があります。例: CREATE DATABASE <YOUR_DATABASE_NAME> DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_general_ci;

4 Talendは、Microsoft SQL Server 2016以降のAlways Encrypted機能をサポートしています。

5 Amazon RDSはサポートされています。

6 次の手順に従い、お持ちのH2データベースを2.1バージョンにアップデートしてください: https://help.talend.com/r/ja-JP/8.0/migration-upgrade-guide-big-data/upgrading-administration-database

7 mssql-jdbc-10.2.1.jre11.jarを使用する場合、datasources.xmlというMDM データソース設定ファイルにあるMS SQL Server 用の接続URLにTrustServerCertificate=Trueというパラメーターを追加する必要があります。

Talend Identity and Access Management

注:

データベースoidcidpに同じデータベースタイプとバージョンを使用します。

Apache Syncopeでサポートされるデータベースは、Apache Syncopeのドキュメンテーションをご覧ください。

Talend Identity and Access Managementと互換性があるデータベース
データベース バージョン サポートされているドライバー サポートタイプ
MySQL 8.0 1、3 mysql-connector-java-8.x.jar 推奨
5.7 サポート
Oracle 19c

ojdbc7-11g.jar

ojdbc7.jar

ojdbc8.jar

ojdbc10.jar

推奨
18c サポート
Azure SQL - お使いのSQLサーバーのバージョンをサポートするMicrosoftドライバーの利用可能な最新バージョンです。詳細は、Microsoftマトリックスをご覧ください。 サポート
H2 4

2.16

h2-2.1.210.jar

本番環境ではサポートされていません
MS SQL Server 2、3 2017 お使いのSQLサーバーのバージョンをサポートするMicrosoftドライバーの利用可能な最新バージョンです。詳細は、Microsoftマトリックスをご覧ください。 サポート
2016 サポート
2014 サポート
PostgreSQL 3 13 postgresql-42.2.2.jre7.jar サポート
12 サポート
11 サポート
10 サポート
9.6 サポート

1 Google Cloud SQLはサポートされています。

2 Talendは、Microsoft SQL Server 2016以降のAlways Encrypted機能をサポートしています。

3 Amazon RDSはサポートされています。

4 開発、テスト、デモ用に組み込まれています。

6 次の手順に従い、お持ちのH2データベースを2.1バージョンにアップデートしてください: https://help.talend.com/r/ja-JP/8.0/migration-upgrade-guide-big-data/upgrading-administration-database

対象製品:

Data Fabric

Data Services Platform

ESB

MDM Platform

Real-Time Big Data Platform

Service Activity Monitoring (SAM)

Service Activity Monitoringと互換性があるデータベース
データベース バージョン サポートされているドライバー サポートタイプ
MySQL 8.0 1、3 mysql-connector-java-8.x.jar 推奨
5.7 サポート
Oracle 19c ojdbc10.jar

ojdbc7-11g.jar

ojdbc7.jar

ojdbc8.jar

推奨
18c サポート
Azure SQL   jtds-1.3.1_patched.jar サポート
Derby DB 10.8以降   サポート
IBM DB2 10.5   サポート
MS SQL Server 2、3 2017 jtds-1.3.1.jar サポート
2016 サポート
2014 サポート
PostgreSQL 3 13 postgresql-42.2.2.jre7.jar サポート
12 サポート
11 サポート
10 サポート
9.6 サポート

1 Google Cloud SQLはサポートされています。

2 Talendは、Microsoft SQL Server 2016以降のAlways Encrypted機能をサポートしています。

3 Amazon RDSはサポートされています。

対象製品:

Data Fabric

Data Services Platform

ESB

MDM Platform

Real-Time Big Data Platform

ESB Service Registry/認証サービス/イベントロギング

ESB Service Registry/Service Activity Monitoring/プロビジョニングサービス/認証/イベントロギングで互換性があるデータベース
データベース バージョン サポートされているドライバー サポートタイプ
MySQL 8.0 1、3 mysql-connector-java-8.x.jar 推奨
5.7 サポート
Oracle 19c ojdbc7-11g.jar

ojdbc7jar

ojdbc8.jar

ojdbc10.jar

推奨
18c サポート
Azure SQL - お使いのSQLサーバーのバージョンをサポートするMicrosoftドライバーの利用可能な最新バージョンです。詳細は、Microsoftマトリックスをご覧ください。 サポート
HSQL 4 2.3.2   サポート
Derby DB 10.8以降   サポート
IBM DB2 5 10.5   サポート
MS SQL Server 2、3 2017 お使いのSQLサーバーのバージョンをサポートするMicrosoftドライバーの利用可能な最新バージョンです。詳細は、Microsoftマトリックスをご覧ください。 サポート
2016 サポート
2014 サポート
PostgreSQL 3 13 postgresql-42.2.2.jre7.jar サポート
12 サポート
11 サポート
10 サポート
9.6 サポート

1 Google Cloud SQLはサポートされています。

2 Talendは、Microsoft SQL Server 2016以降のAlways Encrypted機能をサポートしています。

3 Amazon RDSはサポートされています。

4 製品に組み込み済み。

5 Service Activity Monitoringのみ。

対象製品:

Big Data Platform

Data Fabric

Data Management Platform

Data Services Platform

MDM Platform

Real-Time Big Data Platform

データクオリティデータマート

データクオリティデータマートに互換性があるデータベース
データベース バージョン サポートされているドライバー サポートタイプ
MySQL 8.0 1、3 mysql-connector-java-8.x.jar 推奨
5.7 mysql-connector-java-5.x.jar 推奨
Oracle 19c ojdbc8.jar (サポートされている全バージョンで推奨)

ojdbc7.jar

ojdbc7-11g.jar

ojdbc10.jar
サポート
18c
12c3
11g
Azure SQL - jtds-1.3.1_patched.jar

mssql-jdbc-9.4.0.jre8.jar

mssql-jdbc-9.4.0.jre11.jar

サポート
MS SQL Server 2、3 2017 お使いのSQLサーバーのバージョンをサポートするMicrosoftドライバーの利用可能な最新バージョンです。詳細は、Microsoftマトリックスをご覧ください。 サポート
2016 サポート
2014 サポート
PostgreSQL 3 13 postgresql-42.2.14.jar サポート
12
11 postgresql-42.2.2.jre7.jar サポート
10
9.6
Snowflake - snowflake-jdbc-3.13.8.jar サポート
注:
MySQL を使用している場合は、MySQL サーバーをインストールしたディレクトリーにある my.ini ファイルを編集して、以下の行を追加する必要があります:
max_allowed_packet = 64M

64Mの値は例として挙げられています。この値は、サーバーで扱える最大のクエリーパケットのサイズのみならず、サーバーが処理できる最大クエリーサイズも表します。この値を16Mより大きい任意の値に置き換えることができます。

1 Google Cloud SQLはサポートされています。

2 Talendは、Microsoft SQL Server 2016以降のAlways Encrypted機能をサポートしています。

3 Amazon RDSはサポートされています。

Talend Data Preparation

Talend Data Preparationと互換性があるデータベース
データベース バージョン サポートタイプ
MongoDB 4.0 サポート(製品に組み込み済み)
注: アクティブ/アクティブのクラスタリングはサポートされていないため、本番環境にはお勧めできません。
4.4 サポート
3.6 サポート

Talend Data Stewardship

Talend Data Stewardshipと互換性があるデータベース
データベース バージョン サポートタイプ
MongoDB 4.0 サポート(製品に組み込み済み)
注: アクティブ/アクティブのクラスタリングはサポートされていないため、本番環境にはお勧めできません。
4.4 サポート
3.6 サポート

対象製品:

Big Data Platform

Data Fabric

Data Management Platform

Data Services Platform

MDM Platform

Real-Time Big Data Platform

Talend Dictionary Service

Talend Dictionary Serviceと互換性があるデータベース
データベース バージョン サポートタイプ
MongoDB 4.0 サポート(製品に組み込み済み)
注: アクティブ/アクティブのクラスタリングはサポートされていないため、本番環境にはお勧めできません。
4.4 サポート (製品には含まれない)
3.6 サポート (製品には含まれない)