Zu Hauptinhalt springen Zu ergänzendem Inhalt springen

Kompatible Betriebssysteme

Diese Seite enthält detaillierte Informationen zu den empfohlenen und unterstützten Betriebssystemen für Talend-Produkte.

In der folgenden Dokumentation:

  • Empfohlen: Kennzeichnet eine von Talend auf der Grundlage der bisherigen Erfahrungen und der Nutzung durch die Kunden empfohlenen Umgebung.
  • Unterstützt: Kennzeichnet eine zur Verwendung mit der aufgeführten Komponente bzw. dem angegebenen Dienst unterstützte Umgebung.
  • Unterstützt mit Einschränkungen: Kennzeichnet eine von Talend unterstützte Umgebung, allerdings nur zu bestimmten in Hinweisen erläuterten Bedingungen.

Die kompatiblen Betriebssysteme sind von Ihrer Version von Talend Studio abhängig.

Talend Studio 8.0

Kompatible Linux-Betriebssysteme für Talend Studio 8.0
Betriebssystem (64-Bit) Version Art der Unterstützung
Ubuntu 22.04 Empfohlen
Ubuntu 20.04 Unterstützt
Red Hat Enterprise Linux Server 9 Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Update von Talend Studio ab 8.0 R2023-11.
Red Hat Enterprise Linux Server 8 Unterstützt
Red Hat Enterprise Linux Server 7 Unterstützt
Rocky Linux 9 Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Update von Talend Studio ab 8.0 R2023-11.
Rocky Linux 8 Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Update von Talend Studio ab 8.0 R2022-10.
CentOS 8 Veraltet (Deprecated)
CentOS 7 Veraltet (Deprecated)
Debian 10 Unterstützt
Amazon Linux Amazon Linux 2 Unterstützt

Mindestanforderungen für die Verwendung: 1 vCPU und 2 GB Arbeitsspeicher

Azure Virtual Desktop unter Ubuntu 22.04 Unterstützt

Mindestanforderungen für die Verwendung: 2 vCPU und 8 GB Arbeitsspeicher

Kompatible Microsoft Windows-Betriebssysteme für Talend Studio 8.0
Betriebssystem (64-Bit) Version Art der Unterstützung
Windows 11 Unterstützt
Windows 10 Empfohlen
Windows Server 2022 Unterstützt
Windows Server 2019 Unterstützt
Windows Server 2016 Unterstützt
Windows Server 2012 Unterstützt
Amazon Workspace unter Windows 10 Unterstützt

Mindestanforderungen für die Verwendung: 2 vCPU und 8 GB Arbeitsspeicher

Azure Virtual Desktop unter Windows 10 Unterstützt

Mindestanforderungen für die Verwendung: 8 vCPU und 32 GB Arbeitsspeicher

Kompatible Mac-Betriebssysteme für Talend Studio 8.0
Betriebssystem (64-Bit) Version Art der Unterstützung
Apple MacOS Ventura Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Update von Talend Studio ab 8.0 R2022-12.
Apple MacOS Monterey 12 Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Update von Talend Studio ab 8.0 R2022-10.
Apple MacOS Big Sur 11 Unterstützt

Weitere Informationen zum Start von Talend Studio unter verschiedenen Betriebssystemen finden Sie unter „Starten von Talend Studio“.

Talend Studio 7.3

Kompatible Linux-Betriebssysteme für Talend Studio 7.3
Betriebssystem Version Art der Unterstützung
Ubuntu 18.04 LTS Empfohlen
Red Hat Enterprise Linux Server 8 Unterstützt
Red Hat Enterprise Linux Server 7 Unterstützt
Rocky Linux 8 Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Patch von Talend Studio ab 7.3.1-R2022-10.
CentOS 8 Veraltet (Deprecated)
CentOS 7 Veraltet (Deprecated)
Amazon Linux Amazon Linux 2 Unterstützt
Amazon Linux Amazon Linux Unterstützt
Kompatible Microsoft Windows-Betriebssysteme für Talend Studio 7.3
Betriebssystem (64-Bit) Version Art der Unterstützung
Windows 10 Empfohlen
Windows Server 2019 Unterstützt
Windows Server 2016 Unterstützt
Windows Server 2012 Unterstützt
Kompatible Mac-Betriebssysteme für Talend Studio 7.3
Betriebssystem (64-Bit) Version Art der Unterstützung
Apple MacOS Catalina 10.15 Unterstützt
Apple MacOS Mojave 10.14 Unterstützt
Apple MacOS High Sierra 10.13 Unterstützt

Talend Server-Module

Da Oracle eine Kompatibilitätserklärung für Red Hat RHEL veröffentlicht hat, geht Talend davon aus, dass Oracle Linux für die Versionen unterstützt wird, die den von Talend in den Nutzungsdokumenten aufgeführten RHEL-Versionen entsprechen.

Folgende Servermodule sind betroffen:

  • Talend CI (Talend CommandLine)
  • Talend Runtime
  • Talend SAP RFC Server
Kompatible Linux-Betriebssysteme für Talend Server-Module
Betriebssystem (64-Bit) Version Art der Unterstützung
Red Hat Enterprise Linux Server 8 Empfohlen
Red Hat Enterprise Linux Server 7 Unterstützt
Rocky Linux 9 Unterstützt
Rocky Linux 8 Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Patch von Talend Studio ab 8.0.1-R2022-10.
CentOS 8 Veraltet (Deprecated)
CentOS 7 Veraltet (Deprecated)
Ubuntu 20.04 Empfohlen
Amazon Linux Amazon Linux 2 Unterstützt
Amazon Linux Amazon Linux 2023 Supported for Talend Runtime with limitations:
  • Erfordert ein Monats-Patch von Talend Studio ab 8.0.1-R2024-02.
SUSE Linux Enterprise Server (SLES) 15 Unterstützt für Talend Runtime
Debian 12 Unterstützt für Talend Runtime
Debian 10 Unterstützt
Kompatible Microsoft Windows-Betriebssysteme für Talend Server-Module
Betriebssystem (64-Bit) Version Art der Unterstützung
Windows Server 2022 Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Patch von Talend Studio ab 8.0.1-R2022-10.
Windows Server 2019 Empfohlen
Windows Server 2016 Unterstützt
Windows Server mit AWS 2016 (RTM) Unterstützt

Talend Remote Engine

Kompatible Linux-Betriebssysteme für Talend Remote Engine
Betriebssystem (64-Bit) Version Art der Unterstützung
Red Hat Enterprise Linux Server 9 Empfohlen
Red Hat Enterprise Linux Server 8 Unterstützt
Red Hat Enterprise Linux Server 7 Unterstützt
Rocky Linux 9 Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Patch von Talend Studio ab 8.0.1-R2022-10.
Rocky Linux 8 Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Patch von Talend Studio ab 8.0.1-R2022-10.
CentOS 8 Veraltet (Deprecated)
CentOS 7 Veraltet (Deprecated)
Ubuntu 22 Unterstützt
Ubuntu 20.04 Unterstützt
Amazon Linux Amazon Linux 2023 Unterstützt
Amazon Linux Amazon Linux 2 Unterstützt
SUSE Linux Enterprise Server (SLES) 15 Unterstützt
Debian 12 Unterstützt
Debian 10 Unterstützt
Kompatible Microsoft Windows-Betriebssysteme für Talend Remote Engine
Betriebssystem (64-Bit) Version Art der Unterstützung
Windows Server 2022 Unterstützt mit Einschränkungen:
  • Erfordert ein Monats-Patch von Talend Studio ab 8.0.1-R2022-10.
Windows Server 2019 Empfohlen
Windows Server 2016 Unterstützt
Windows Server mit AWS 2016 (RTM) Unterstützt
InformationshinweisAnmerkung: Talend empfiehlt die Installation von Talend Remote Engine mit einem x86-64-Prozessor. Talend Installer bietet zurzeit nur Unterstützung für Talend Remote Engine mit einem Prozessor vom Typ x86-64.

Remote Engine Gen2

Kompatible Linux-Betriebssysteme für Remote Engine Gen2
Betriebssystem (64-Bit) Version Art der Unterstützung
Red Hat Enterprise Linux Server 8 Empfohlen
Red Hat Enterprise Linux Server 7 Unterstützt
Rocky Linux 8 Unterstützt
CentOS 8 Veraltet (Deprecated)
CentOS 7 Veraltet (Deprecated)
Ubuntu 20.04 Empfohlen
Amazon Linux Amazon Linux 2023 Unterstützt
Amazon Linux Amazon Linux 2 Veraltet (Deprecated)
Debian 12 Unterstützt

Remote Engine Gen2 bietet keine Unterstützung für Windows, da Windows mit Docker-Containern nicht unterstützt wird. Zwar ist die Windows-Archivdatei zum Download verfügbar, sie enthält jedoch nur eine .bat-Datei zu Entwicklungszwecken.

InformationshinweisAnmerkung: Talend empfiehlt die Installation von Remote Engine Gen2 mit einem x86-64-Prozessor. Talend Installer bietet zurzeit nur Unterstützung für Remote Engine Gen2 mit einem Prozessor vom Typ x86-64.

Erklärung zu Virtualisierungs- und Docker-Implementierungen

Talend unterstützt eine Ausführung auf virtuellen Maschinen und Docker-Containern. Sowohl für Virtualisierungssysteme als auch für Linux-basierte Docker-Container stützt sich Talend auf die Kompatibilitätserklärungen der Anbieter, um einen ordnungsgemäßen Betrieb und eine fehlerfreie Ausführung der Talend-Software zu gewährleisten.

Talend stellt keine vorpaketierten Docker-Images oder Dockerfiles für Talend-Anwendungen bereit.

Hat diese Seite Ihnen geholfen?

Wenn Sie Probleme mit dieser Seite oder ihren Inhalten feststellen – einen Tippfehler, einen fehlenden Schritt oder einen technischen Fehler –, teilen Sie uns bitte mit, wie wir uns verbessern können!