Exporter les paramètres du datamart de rapports en tant que contextes - Cloud - 7.3

Guide d'utilisation du Studio Talend

Version
Cloud
7.3
Language
Français
Product
Talend Big Data
Talend Big Data Platform
Talend Cloud
Talend Data Fabric
Talend Data Integration
Talend Data Management Platform
Talend Data Services Platform
Talend ESB
Talend MDM Platform
Talend Real-Time Big Data Platform
Module
Studio Talend
Content
Création et développement
Disponible dans...

Big Data Platform

Data Fabric

Data Management Platform

Data Services Platform

MDM Platform

Real-Time Big Data Platform

Avant de commencer

  • Vous avez défini les paramètres du datamart de rapports dans la fenêtre Preferences, comme expliqué dans Configurer une base de données distante.
  • Vous avez sélectionné la perspective Profiling.

Pourquoi et quand exécuter cette tâche

Afin d'exporter les paramètres de la base de données de rapports en tant que contexte et utiliser les variables de contexte dans l'éditeur de rapports, procédez comme suit :

Procédure

  1. Dans la barre de menu, sélectionnez Window > Preferences afin d'ouvrir la fenêtre Preferences.
  2. Commencez à saisir Reporting dans le champ de filtre et sélectionnez Reporting dans la liste.
  3. Cliquez sur Export as context afin d'ouvrir l'assistant de création de contextes.
  4. Suivez les étapes dans l'assistant afin de définir les variables de contexte et exportez la connexion au datamart ainsi que le chemin vers le dossier de rapports et le logo en tant que contextes.
    Un nom par défaut est donné aux variables de contexte si vous ne changez pas ce dernier dans l'assistant de création de contextes. Les variables de contexte sont centralisées sous le nœud Context dans l'arborescence DQ Repository.
    Pour plus d'informations concernant la centralisation des contextes dans le référentiel du Studio, consultez Centraliser les variables de contexte dans le Repository.
    Un message apparaît afin de montrer la progression de l'opération.
  5. Vous pouvez cliquer sur Revert Context afin de revenir à l'état initial de la connexion.
  6. Dans l'arborescence DQ Repository, cliquez-droit sur une ou plusieurs analyse·s et générez un rapport.
    L'éditeur de rapports s'ouvre dans les paramètres de rapport.
    Dans la vue Database Connection Settings en bas de l'éditeur, les paramètres de connexion sont déjà remplis avec les variables de contextes définies et exportés en tant que contexte dans la fenêtre Preferences.
    La vue Context group Settings s'ouvre également dans l'espace de modélisation graphique.
    La vue Contexts affiche les variables que vous avez exportées et centralisées dans le référentiel du Studio sous le nœud Contexts de l'arborescence DQ Repository. Si cette vue n'est pas ouverte dans le Studio, utilisez le menu Window > Show View > Profiling > Contexts pour l'ouvrir.
    A faire : Un rapport créé dans le Studio avant que vous ayez défini et exporté les variables de contexte garde ses paramètres de base de données originaux. Si vous souhaitez l'utiliser avec un datamart ou des contextes de connexion différents, vous devez ouvrir le rapport et sélectionner la connexion de contexte manuellement dans l'éditeur de rapports. Pour plus d'informations, consultez Sélectionner ou modifier les variables de contexte dans l'éditeur de rapports.
  7. Sauvegardez le rapport et exécutez-le.
    Les résultats du rapport sont écrits dans la connexion de contexte définie dans l'éditeur de rapports.