Environnements Java Runtime Environment compatibles - 8.0

Guide d'installation et de migration de Talend Data Catalog

Version
8.0
Language
Français
Operating system
Linux
Product
Talend Big Data Platform
Talend Data Fabric
Talend Data Management Platform
Talend Data Services Platform
Talend MDM Platform
Talend Real-Time Big Data Platform
Module
Talend Data Catalog
Content
Installation et mise à niveau
Last publication date
2024-01-29
Pour utiliser Talend Data Catalog, Java doit être installé sur votre machine. Le tableau suivant fournit des informations relatives aux JRE (Java Runtime Environments) supportés.

Dans la documentation suivante :

  • Recommandé : désigne un environnement recommandé par Talend sur la base des expériences de l'entreprise et de l'utilisation faite par les clients ;
  • Supporté : désigne un environnement supporté pour une utilisation avec les composants ou services listés ;
  • Supporté avec limitations : désigne un environnement qui est supporté par Talend sous certaines conditions détaillées dans des notes.
Type de support Verslon JRE Note
Recommandé OpenJDK 11 - 64 bits Vous n'avez pas besoin de configurer OpenJDK 11 car il est embarqué dans Talend Data Catalog.
Remarque : Talend n'offre pas de support pour les JRE embarqués.
Remarque : Les ponts Java sont compilés pour être compatibles avec JRE 8 car certains ponts Java dépendent du SDK de l'outil, qui n'est pas toujours compatible avec OpenJDK 11. La version plus ancienne du SDK de l'outil fonctionne uniquement avec les anciennes versions comme Java 8. Dans ces cas, le pont essaye automatiquement de s'exécuter avec la JRE embarquée avec le logiciel. Lorsque cela n'est pas possible, le pont offre la possibilité de pointer manuellement vers une JRE compatible, dans le paramètre Divers du pont. Les ponts pour les outils ayant des problèmes de compatibilité avec OpenJDK 11 comprennent au moins Oracle Data Integration et SAP BusinessObjects.
Les autres environnements Java Runtime Environment comme IBM Java nécessitent une installation/configuration manuelles et ne sont, par conséquent, pas supportés par cette version.