跳到主要内容 跳到补充内容

兼容的数据库

下表提供了有关可用于 Talend 服务器模块的建议和受支持数据库的信息。除非另有说明,否则此列表适用于独立(或单节点)数据库配置。

在下面的文档中:

  • 建议:指定由 Talend 根据我们的经验和客户使用情况建议的环境。
  • 支持:指定支持用于所列组件或服务的环境。
  • 带限制的支持:指定受 Talend 支持但具有说明中交待的某些条件的环境。

Talend Administration Center

Talend Administration Center 的兼容数据库
数据库 版本 支持的驱动 支持类型
MySQL4,5 8.0 mysql-connector-java-8.x.jar 建议
5.7 支持
Oracle 19c ojdbc10.jar

ojdbc8.jar

建议
18c 支持
Azure SQL - mssql-jdbc-9.4.0.jre11.jar

mssql-jdbc-9.4.0.jre8.jar

支持
H2 1 2.16 h2-2.1.210.jar 生产环境下不支持
MariaDB 2 10.5 mariadb-java-client-2.7.4.jar 支持
MS SQL Server 3 2022 mssql-jdbc-12.2.0.jre8.jar

mssql-jdbc-12.2.0.jre11.jar

支持
2019 mssql-jdbc-10.2.0.jre11.jar

mssql-jdbc-10.2.0.jre8.jar

mssql-jdbc-9.4.0.jre11.jar

mssql-jdbc-9.4.0.jre8.jar

支持
2017 支持
2016 支持
2014 支持
PostgreSQL 15 postgresql-42.5.3.jar 支持
14 支持
13 支持
12 支持
11 支持
10 支持
9.6 支持
Aurora 3 mysql-connector-java-8.0.33.jar 支持
2.07.2 mysql-connector-java-8.0.26.jar 支持
信息注释注: 无论托管模式如何,上述所有数据库 (包括 Google 云平台和 Amazon RDS) 都受到支持。

1 嵌入式,仅用于开发、测试和演示目的。如果您从以前的版本迁移过来,则不支持 H2。要从以前的版本迁移,您需要先在源版本中从 H2 迁移到 MySQL 或其它受支持的数据库,然后触发 Talend Administration Center 向目标版本的升级。

2 用 MariaDB 10.1 创建数据库 schema 时,请务必使用 UTF8 编码格式。例如:CREATE DATABASE <YOUR_DATABASE_NAME> DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_general_ci;

3 Talend 支持 Microsoft SQL Server 2016 或更高版本的 Always Encrypted 特性。Talend Administration Center 支持 MSSQL 集群。

4 Talend Administration Center 支持 MySQL InnoDB 集群。使用 InnoDB 集群时,您可能需要将 JDBC URL 更改为集群系统 env,例如 JDBCUrl:jdbc:mysql://192.168.1.32:6446/TAC?useSSL=true&connectTimeout=15000&socketTimeout=15000&autoReconnect=true。IP 地址 192.168.1.32 和端口 6446 是 mysqlrouter 主机的 IP 地址和 mysql 路由器的 RW 端口。

My MySQL Route Classic 协议: 读写连接localhost:6446 只读连接: localhost:6447

5 Talend Administration Center 支持 Red Hat clustering 故障切换配置中的 MySQL 设置。有关更多信息,请参阅https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/high_availability_add-on_administration/index。请留意您可能需要在JDBC连接的 URL中添加不同的参数,参4中所示。

6 将 H2 数据库更新到 2.1 版本,请参见 升级管理数据库

Talend MDM Server

Talend MDM Server 的兼容数据库
数据库 版本 支持的驱动 支持类型
MySQL 1,5 8.0 mysql-connector-java-8.x.jar 建议
5.7 支持
Oracle 19c ojdbc10.jar

ojdbc8.jar

建议
18c 支持
Azure SQL - jtds-1.3.1_patched.jar 支持
H2 2 2.16 h2-2.1.210.jar 生产环境下不支持
IBM DB2 10.5 db2jcc.jar 支持
MS SQL Server 2019 mssql-jdbc-9.4.0.jre11.jar

mssql-jdbc-10.2.1.jre11.jar 7

支持
2017 5 mssql-jdbc-9.2.1.jre8.jar

mssql-jdbc-9.2.1.jre11.jar

支持
2016 支持
2014 支持
PostgreSQL 13 postgresql-42.2.2.jre7.jar 支持
12 支持
11 支持
10 支持
9.6 支持

1 支持 Google Cloud SQL。

2 嵌入式,仅用于开发、测试和演示目的。

3 用 MariaDB 10.1 创建数据库 schema 时,请务必使用 UTF8 编码格式。例如:CREATE DATABASE <YOUR_DATABASE_NAME> DEFAULT CHARACTER SET utf8 DEFAULT COLLATE utf8_general_ci;

4 Talend 支持 Microsoft SQL Server 2016 或更高版本的 Always Encrypted 特性。

5 支持 Amazon RDS。

6 按照以下程序将 H2 数据库更新到 2.1 版本:升级管理数据库

7 使用 mssql-jdbc-10.2.1.jre11.jar 时,MDM 数据源配置文件 datasources.xml 中的 MS SQL Server 的连接 URL 需附有 TrustServerCertificate=True 参数。

Talend Identity and Access Management

信息注释注:

oidc 数据库使用相同的数据库类型和版本。

Talend Identity and Access Management 的兼容数据库
数据库 版本 支持的驱动 支持类型
MySQL 8.0 1, 3 mysql-connector-java-8.x.jar 建议
5.7 支持
Oracle 19c

ojdbc7-11g.jar

ojdbc7.jar

ojdbc8.jar

ojdbc10.jar

建议
18c 支持
Azure SQL - 支持您的 SQL Server 版本的 Microsoft 驱动程序的最新可用版本。有关更多信息,请查看 Microsoft matrix (仅提供英文版本) 支持
H2 4 2.16

h2-2.1.210.jar

生产环境下不支持
MS SQL Server 2,3 2017 支持您的 SQL Server 版本的 Microsoft 驱动程序的最新可用版本。有关更多信息,请查看 Microsoft matrix (仅提供英文版本) 支持
2016 支持
2014 支持
PostgreSQL 3 13 postgresql-42.2.2.jre7.jar 支持
12 支持
11 支持
10 支持
9.6 支持

1 支持 Google Cloud SQL。

2 Talend 支持 Microsoft SQL Server 2016 或更高版本的 Always Encrypted 特性。

3 支持 Amazon RDS。

4 嵌入式,仅用于开发、测试和演示目的。

6 请按此步骤将 H2 数据库升级到 2.1 版本: https://help.talend.com/r/zh-CN/8.0/migration-upgrade-guide/upgrading-administration-database.

服务活动监控 (SAM)

服务活动监控 的兼容数据库
数据库 版本 支持的驱动 支持类型
MySQL 8.0 1, 3 mysql-connector-java-8.x.jar 建议
5.7 支持
Oracle 19c ojdbc10.jar

ojdbc7-11g.jar

ojdbc7.jar

ojdbc8.jar

建议
18c 支持
Azure SQL   jtds-1.3.1_patched.jar 支持
Derby DB 10.8 (或更新版本)   支持
IBM DB2 10.5 db2jcc.jar 支持
MS SQL Server 2,3 2017 jtds-1.3.1.jar 支持
2016 支持
2014 支持
PostgreSQL 3 13 postgresql-42.2.2.jre7.jar 支持
12 支持
11 支持
10 支持
9.6 支持

1 支持 Google Cloud SQL。

2 Talend 支持 Microsoft SQL Server 2016 或更高版本的 Always Encrypted 特性。

3 支持 Amazon RDS。

ESBService Registry/授权

ESB 的兼容数据库Service Registry/服务活动监控/调配服务/授权
数据库 版本 支持的驱动 支持类型
MySQL 8.0 1, 3 mysql-connector-java-8.x.jar 建议
5.7 支持
Oracle 19c ojdbc7-11g.jar

ojdbc7.jar

ojdbc8.jar

ojdbc10.jar

建议
18c 支持
Azure SQL - 支持您的 SQL Server 版本的 Microsoft 驱动程序的最新可用版本。有关更多信息,请查看 Microsoft matrix (仅提供英文版本) 支持
HSQL 4 2.3.2   支持
Derby DB 10.8 (或更新版本)   支持
IBM DB2 5 10.5 db2jcc.jar 支持
MS SQL Server 2,3 2017 支持您的 SQL Server 版本的 Microsoft 驱动程序的最新可用版本。有关更多信息,请查看 Microsoft matrix (仅提供英文版本) 支持
2016 支持
2014 支持
PostgreSQL 3 13 postgresql-42.2.2.jre7.jar 支持
12 支持
11 支持
10 支持
9.6 支持

1 支持 Google Cloud SQL。

2 Talend 支持 Microsoft SQL Server 2016 或更高版本的 Always Encrypted 特性。

3 支持 Amazon RDS。

4 嵌入在产品中。

5 仅限 Service Activity Monitoring。

数据质量数据集市

数据质量数据集市的兼容数据库
数据库 版本 支持的驱动 支持类型
MySQL 8.0 1, 2, 3 mysql-connector-java-8.x.jar 建议
5.7 mysql-connector-java-5.x.jar 建议
Oracle 19c ojdbc8.jar (对于所有受支持版本推荐使用此 jar 包)

ojdbc7.jar

ojdbc7-11g.jar

ojdbc10.jar
支持
18c
12c3 (自 8.0.1 R2023-01 起已弃用)
11g (自 8.0.1 R2023-01 起已弃用)
Azure SQL - jtds-1.3.1_patched.jar

mssql-jdbc-9.4.0.jre8.jar

mssql-jdbc-9.4.0.jre11.jar

支持
MS SQL Server 3,4 2017 支持您的 SQL Server 版本的 Microsoft 驱动程序的最新可用版本。有关更多信息,请查看 Microsoft matrix (仅提供英文版本) 支持
2016 支持
2014 支持
PostgreSQL 3 13 postgresql-42.2.14.jar 支持
12
11 postgresql-42.2.2.jre7.jar 支持
10
9.6
Snowflake - snowflake-jdbc-3.13.8.jar 支持

1 支持 Google Cloud SQL。

2Talend Studio 8.0 R2023-07 开始,支持 MySQL InnoDB 集群。

3 支持 Amazon RDS。

4 Talend 支持 Microsoft SQL Server 2016 或更高版本的 Always Encrypted 特性。

信息注释重要: 如果您使用 MySQL,则必须在 MySQL 服务器安装目录的 my.ini 文件中添加下面一行:
max_allowed_packet = 64M
64M 值只是举例。它表示服务器能够处理的队列数据包的最大大小以及服务器能够处理的最大队列大小。您可以将其替换为比 16M 更好的任何值。

Talend Data Preparation

Talend Data Preparation 的兼容数据库
数据库 版本 支持类型
MongoDB 7.0 支持
5.0 支持

Talend Data Stewardship

Talend Data Stewardship 的兼容数据库
数据库 版本 支持类型
MongoDB 7.0 支持
5.0 支持

Talend Dictionary Service

Talend Dictionary Service 的兼容数据库
数据库 版本 支持类型
MongoDB 7.0 支持
5.0 支持

本页面有帮助吗?

如果您发现此页面或其内容有任何问题 – 打字错误、遗漏步骤或技术错误 – 请告诉我们如何改进!