跳到主要内容 跳到补充内容

兼容的操作系统

本页详细列出 Talend 产品的建议和受支持操作系统。

在下面的文档中:

  • 建议:指定由 Talend 根据我们的经验和客户使用情况建议的环境。
  • 支持:指定支持用于所列组件或服务的环境。
  • 带限制的支持:指定受 Talend 支持但具有说明中交待的某些条件的环境。

Talend Studio

Talend Studio 兼容的操作系统
操作系统系列 (64 位) 操作系统 版本 支持类型
Linux Ubuntu 22.04 建议
20.04 支持
Red Hat Enterprise Linux Server 9 支持 5
8 支持3
7 支持
Rocky Linux 9 支持 5
8 支持3
CentOS 8 已弃用
7 已弃用
Debian 10 支持
Amazon Linux Amazon Linux 2 支持
Microsoft Windows 11 支持
10 建议
Windows Server 2022 支持3
2019 支持
2016 支持
2012 支持
Mac Apple MacOS Ventura 支持4
Monterey 12 支持3
Big Sur 11 支持
Amazon Workspace Amazon Linux Amazon Linux 2 支持1
Windows 10 支持2
Azure 虚拟桌面 Ubuntu 22.04 支持 5
Windows 10 支持 5

1 最低使用需求: 1 vCPU 及 2 GB 内存。

2 最低使用需求: 2 vCPU 及 8 GB 内存。

3 需要安装 8.0 R2022-10 Talend Studio 月度更新或更高版本的更新。

4 需要安装 8.0 R2022-12 Talend Studio 月度更新或更高版本的更新。

5 需要安装 8.0 R2023-11 Talend Studio 月度更新或更高版本的更新。

有关在不同操作系统中如何启动 Talend Studio 的更多信息,请参阅 Launching Talend Studio (英文版)

Talend 服务器模块

鉴于 Oracle 已发表针对 Red Hat Enterprise Linux (RHEL) 的兼容性声明,Talend 认为对应于 Talend 在《用户文档》中列出的 RHEL 版本的 Oracle Linux 版本受支持。

服务器模块包括:

  • Talend Administration Center
  • Talend Data Preparation
  • Talend Data Stewardship
  • Talend Dictionary Service
  • Talend ESB 服务器
  • Talend JobServer
  • Talend LogServer(已弃用)
  • Talend MDM Server(已弃用)
  • Talend Runtime
  • Talend Identity and Access Management
  • Talend SAP RFC Server
  • Talend CI (Talend CommandLine)
Talend 服务器模块的兼容操作系统
操作系统系列 (64 位) 操作系统 版本 支持类型
Linux Red Hat Enterprise Linux Server 9 支持所有模块,但 Talend LogServer 除外(已弃用)
8 支持所有模块
7 支持所有模块
Rocky Linux 9 支持
8 支持1
CentOS 8 已弃用
7 已弃用
Debian 12 支持 Talend Administration CenterTalend JobServerTalend Runtime
10 支持
Ubuntu 22.04 LTS 建议用于 Talend Administration Center
20.04 LTS 建议用于所有模块
SUSE Linux Enterprise Server (SLES) 15 支持
Amazon Linux Amazon Linux 2023 支持2 Talend Administration CenterTalend JobServerTalend Runtime
Amazon Linux 2 支持
Microsoft Windows Server 2022 支持1
2019 建议
2016 支持
Windows Server on AWS 2022 支持
2016 支持

3 需要安装 8.0.1-R2022-10 Talend 月度更新或更新版本的补丁。Talend LogServer 已经弃用,因此不支持这些版本的操作系统。

2 需要安装 8.0.1-R2024-02 Talend 月度更新或更新版本的补丁。

关于虚拟化和 Docker 部署的声明

Talend 支持在虚拟机和 Docker 容器上运行。对虚拟化系统和基于 Linux 的 Docker 容器而言,Talend 都依赖供应商的兼容性声明来确保 Talend 软件的正确运行和执行。

Talend 没有为 Talend 应用程序提供预打包的 Docker 镜像或 Dockerfile。

本页面有帮助吗?

如果您发现此页面或其内容有任何问题 – 打字错误、遗漏步骤或技术错误 – 请告诉我们如何改进!