Accéder au contenu principal

Bases de données supportées ou systèmes métier supportés pour les composants Talend

Cette section liste les versions des bases de données, systèmes, applications métier et systèmes d'exploitation compatibles avec vos Jobs Talend. L'accès à ces versions dépend de la version mensuelle du Studio Talend que vous utilisez. Pour plus d'informations, consultez les Notes de version de Talend.
Systèmes Versions Système d'exploitation
Access
  • 2003
  • 2007
Note InformationsRemarque : Lorsque vous travaillez avec Java 8, seul le mode General collation est supporté.
Windows
AlloyDB Inapplicable Inapplicable
Amazon Aurora MySQL, édition v5 (5.6 et 5.7) Inapplicable
Amazon AWS Redshift Spectrum Inapplicable Inapplicable
Amazon Redshift 2.x Inapplicable
Amazon S3 Inapplicable Inapplicable
Amazon Simple Queue Service (Amazon SQS) Inapplicable Inapplicable
AS/400 V6R1 à V7R2, V7R1 à V7R3 Inapplicable
Cassandra 4.x Windows + Linux
CouchBase
  • 6.0
  • 5.x
Windows
CouchDB 1.0.2 Windows
CyberArk 12.x Inapplicable
DB2
  • 11.x
  • 10.5 (et jusqu'à 11)
Inapplicable
Base de données générique ODBC Windows
DynamoDB Inapplicable Inapplicable
Elasticsearch 6.4.x pour les Jobs Spark Streaming Inapplicable
Elasticsearch
  • 8.x pour les Jobs Spark Batch
  • 7.x pour les Jobs Spark Batch
Inapplicable
Exasol Jusqu'à la version 6 Windows
Excel Inapplicable Inapplicable
eXist-db 1.4.0 Inapplicable
Firebird 2.1 Windows + Linux
FTP Inapplicable Inapplicable
Greenplum
  • 6.x
  • 5.x
  • 4.3.x
Windows (client uniquement) + Linux
HSQLdb 1.8.0 à 2.4 Inapplicable
IBM DB2 et IBM DB2 Z/OS 11.x Windows + Linux
Informix 11.50 Windows + Linux
Ingres
  • 11
  • 10.2
Windows + Linux
Interbase Inapplicable Inapplicable
JavaDB 6 Windows + Linux
JDBC Inapplicable Inapplicable
JSON Inapplicable Inapplicable
Kafka
  • 3.3.x
  • 3.2.x
Note InformationsRemarque : Les options Kerberos Kinit et Kerberos Keytab sont supportées. Pour plus d'informations concernant les options de sécurité supportées par les composants Kafka, consultez Utilisation de Kafka sécurisé dans le Studio.
Windows + Linux
LDAP Pas de limitation de version Windows + Linux
MapRDB Inapplicable Inapplicable
MarkLogic 9 Inapplicable
MaxDB 7.6 Inapplicable
Stockage Blob Microsoft Azure Inapplicable Inapplicable
Microsoft Azure Synapse Analytics Inapplicable Inapplicable
Microsoft AX
  • Dynamics AX 2012
  • Dynamics AX 4.0
Inapplicable
Microsoft CRM
  • 2016
  • 2015
  • 2011
Inapplicable
Microsoft CRM Online
  • 2018
  • 2016
  • 2011
Inapplicable
Microsoft SQL Server
  • Amazon RDS
  • 2014 jusqu'à la dernière version
Note InformationsRemarque : Le support de Microsoft SQL Server est fourni via Microsoft SQL JDBC Driver. Pour plus d'informations, consultez Télécharger Microsoft JDBC Driver pour SQL Server.
Windows + Linux
MongoDB
  • 4.4.x et versions suivantes pour les Jobs Spark Batch et Spark Streaming
  • 4.4.x et supérieures pour les Jobs Standard
Windows + Linux
MySQL
  • Google Cloud SQL
  • Amazon RDS
  • MariaDB 10.x
  • MySQL 8.x
  • MySQL 5.x
Windows + Linux
MOM Inapplicable Inapplicable
Neo4j
  • 4.x.x
  • 3.5.x
  • 3.2.x
Windows + Linux
Netezza
  • 11.x
  • 7.2.x
  • 7.1.x
  • 7.0.x
Windows + Linux
NetSuite
  • 2021.2
  • 2019.2
  • 2018
Windows + Linux
Oracle
  • Amazon RDS
  • Oracle 19c
  • Oracle 18c
Windows + Linux
Oracle Versions dépréciées : 12 - 7/11 Inapplicable
Palo Version 5 open source Inapplicable
ParAccel
  • 3.5
  • 3.1
Inapplicable
PostgreSQL
  • Microsoft Azure
  • Google Cloud SQL
  • Amazon RDS
  • 12 et supérieures
Windows + Linux
PostgresPlus est supporté via PostgreSQL
  • 9 et supérieures
  • 8.2
Windows + Linux
Red Hat BRMS 6.1 Windows + Linux
Service REST Inapplicable Windows + Linux
Salesforce
  • 57
  • Jusqu'à la version 52
Windows + Linux
SAP 4.6 Windows + Linux
SAP Business Suite (ERP)
  • ERP6.0, de EhP6 à EhP8
  • Netweaver : de 7.3 à 7.5
Windows + Linux
SAP Business Warehouse (BW)
  • ERP6.0, de EhP6 à EhP8
  • Netweaver : de 7.3 à 7.5
Windows + Linux
SAP HANA Pas de limitations de version
Note InformationsRemarque : Supportées via le pilote SAP JDBC.
Windows + Linux
SAP BW/4HANA Composants DSO Windows + Linux
SAP BW sur HANA Composants ADSO Windows + Linux
Snowflake Inapplicable Inapplicable
ServiceNow Inapplicable Inapplicable
Service SOAP Inapplicable Inapplicable
SQLite 3.6.7 Windows + Linux
Sybase
  • 17.0
  • 16.0
  • 15.7
  • 15.5
  • 15.2
  • 12.7
  • 12.5
Windows + Linux
SybaseIQ
  • 16.0
  • 15.2
  • 12.7
  • 12.5
Windows + Linux
Teradata 12 à 17 Windows + Linux
VectorWise 2 Windows + Linux
Vertica
  • 9.0.x à 9.3.1
  • 12.x
Windows + Linux
VtigerCRM
  • Vtiger 5.1
  • Vtiger 5.0
Inapplicable
Workday Inapplicable Non applicable

Cette page vous a-t-elle aidé ?

Si vous rencontrez des problèmes sur cette page ou dans son contenu – une faute de frappe, une étape manquante ou une erreur technique – dites-nous comment nous améliorer !